Announcement

Collapse
No announcement yet.

GSoft download

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts


  • GSoft download

    I have several GS2 drives to load the same configuration into. Why do I have to download the configuration to the drive 3 to 4 times before it will accept the change to P3.02? I want to use this DI as Multi-Speed Bit 1 (03). The first few times I download the configuration, the drive will accept all the changes but this one. I don't know that I am doing anything other than changing P3.02 to 03 and downloading again. Finally, it will accept. Is there another parameter that I need to change for the drive to accept this value the first time?

    Thanks,


  • #2
    Many parametes in drives require a power cycle or soft reset after downloading before they are used. Others are in effect immediately after downloading. This is also true if parameters are changed one at a time possibly by a link with a place. The manual should define which require the power cycle or soft reset.
    thePLCguy

    Bernie

    Comment



    • #3
      The parameter that seems to be the problem is P3.02 Default is 00 and if I try to change it, it get a message something to the effect that the drive has changed the parameter that I have tried to load. If I manually change P3.02 to 99, input disabled, I can load the configuration with P3.02 as 03, which is what I want, it will accept it. Guess I will make a configuration that disables DI3 to DI6, load it and then load the configuration I really want. Only have to load the configuration twice that way.

      Comment



      • #4
        The setting in P3.01 seems to have control of DI3 if Mode 02 is selected. If That is the case then you need to use another input for multi-speed select.
        Last edited by bcarlton; 09-27-2018, 02:25 PM.
        thePLCguy

        Bernie

        Comment



        • #5
          I've seen similar issues with other brands of drives. Basically one of the parameters is a macro, and once set, and the drive reset, then it assigns i/o... which may over-write one that you had set to something else, arrg! So, if you download it, reset, then download again, the 2nd time, the macro has already been set, so nothing happens, and the new assignment for that one DI takes effect...

          May be the case here.

          Comment



          • #6
            These are brand new out of the box drives. I have found that if I change Parameters P3.02 to P3.05 all to 99 manually before I download the configuration, the parameters will change to what I need without a problem when I download. This is at least better than what Tech Support told me. Said he changes the configuration manually, doesn't use GSoft, takes too long????

            Comment



            • #7
              Since the default setting of P3.01 is 00 it should not be a problem on a new drive.

              Since P3.03 - P3.05 are set to 'multi-speed' inputs by default you would have to be sure to provide a new value for all of them so that you aren't trying to assign the same function to two different pins. And remember, these can't be changed in run mode, only when stopped.

              Just a guess - if GSoft sends the changes one at a time it may be encountering the 'duplicate function' problem. This is what your 'all 99s' procedure seems to point to.
              Last edited by bcarlton; 10-02-2018, 07:09 PM.
              thePLCguy

              Bernie

              Comment



              • #8
                Thanks, Bernie. I had come to the conclusion that the problem was caused by trying to assign a function to a DI and that function was already assigned to another, although when I tried to assign 99 to all the DI in GSoft didn't seem to work. I have about 15 more of these drives to configure so I'll be doing some more experimenting.

                Comment

                Working...
                X