Announcement

Collapse
No announcement yet.

Configure GS3 for Yaskawa UAASKA motor with 1024 PPR feedback

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts


  • Configure GS3 for Yaskawa UAASKA motor with 1024 PPR feedback

    I am leery of blowing anything up so........ I am setting up a GS3 with a Yaskawa UAASKA motor. Have not connected the encoder as yet, so set up the drive for sensorless vector and tried running the AutoTune. AutoTune errored out with an overload fault during the test and the GS3 did not update the motor values.

    The manual is pretty vague on setting up for encoder feedback.
    Once I wire up the encoder I need to set P2.10. Are there other setting that are specific to vector control that need to be setup?

    In my case this motor is driving a 6 speed Deckel gearbox so low speed torque should be much less of an issue than for most situations. Is it OK to setup the encoder feedback before running AutoTune?

    Thanks for the guidance.

    Erik Green
    Last edited by gernoff; 10-06-2018, 10:42 PM.


  • #2
    What sort of motor is it? Induction? Motor data and drive data?

    Comment



    • #3
      It is an induction motor. 3.7kw continuous 5.5kw max (30 min). Includes 1024ppr encoder.
      I now have the encoder connected and all settings look correct......
      Autotune will detect winding resistance fine. But still errors out detecting no load current. Set spindle speed at 50hz and hit run. motor seems to 'hunt' but does not spin up to speed.
      Thoughts?

      Comment



      • #4
        You set your motor horsepower, voltage, amperage, and RPMs correctly in the GS3?
        And you are running auto tune with no load connected to the motor right?

        Comment



        • #5
          Yes........ Ish. The UAASKA-06 spindle motor is rated at 200 volts and 3.7kw continuous / 5.5kw for 30 minutes. But, the listed amperage is 29A continuous and 39A max (high for those kw ratings). I will be more than happy if it works at the 25A rating of my GS3. 25A at 230v is close enough to the rated 29A at 200v spec of teh motor.
          Its manual states that is can be operated at 200v, 220v or 230 volts and 50 or 60hz.
          Since I have 230VAC from my Phase Perfect, I configured it at 230volts, 50hz, 25A, base speed of 1500rpm and max of 5000.
          The encoder is working OK, set for 1024ppr and P10.01 is set to Quadrature FWD = CW. P & I and Output Limit set at defaults of 1 1.00 and 7.5%
          P2.10 control mode is 03 Sensorless with Encoder Feedback (Should I try V/Hz?)
          As stated above, autotune will detect resistance but fails out if i try to test for no load amps.
          If I set the speed to 50hz and hit run, the motor seems to hunt and not spin up to speed, I have the accel set at .5sec and also tried 4 seconds. Either way the motor does not accelerated and watching the output current I see it climb up towards 35A in about 1-2 seconds and hit stop at that point.
          Last edited by gernoff; 10-10-2018, 10:46 PM. Reason: ,

          Comment



          • #6
            If it were me...

            I'd start with trying to run the motor in straight V/F mode. 200V / 60hz / 1800rpm, and reasonable 5 second or so accel/decel. Watch the amps. This is the lowest v/f setting per the nameplate data you mentioned.

            Once you can get it running and are cerrtain the drive can run the motor, then try a closed loop setting and tune. Tune it at base speed (1800rpm/60hz), then try the over-speed setting, and watch it.

            I will be more than happy if it works at the 25A rating of my GS3. 25A at 230v is close enough to the rated 29A at 200v spec of teh motor.
            No, it's not. Your drive should be rated as high, or higher than the motor. Anything less is asking for trouble and intermittent trips.

            Comment



            • #7
              I would imagine that the motor is simply trying to draw way too many amps from the drive. You will want a drive rated for 40A or so to be able to handle the maximum draw of your motor, or a different motor that fits within the drive ratings. When I just looked up 3.7kw, it tells me that is a 5.5HP motor. And 5.5kw is a 7HP motor. So you should be able to replace the motor with one that draws a more normal numbers of amps since you will still be able to get the same horsepower. This 7.5HP motor has a full load current draw of 21 amps in 230v mode and comes with an encoder for closed loop vector:
              https://www.automationdirect.com/adc...0HP)/Y545-A772

              The only issue I can see is that it is not rated for 5000RPM. Do you really need such high RPMs on your motor? What is the typical and maximum speed your motor will be running in its application?
              Also be sure and compare full load torque and breakdown torque of this motor and the one that you have. I am wondering if your motor with extremely high amps will have a drastically higher torque rating.
              Last edited by MikeN; 10-11-2018, 09:20 AM.

              Comment

              Working...
              X