Announcement

Collapse
No announcement yet.

GS3 Drive: Load % update issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts


  • GS3 Drive: Load % update issue

    All,

    I have the following:

    Drive: GS3-4030, with Zip Link cable to #2 port on PLC, RS-485
    PLC: DL06
    HMI: EA9-T10WCL.

    The issue I am having is that I am motoring the motor load % from the GS3 drive in the PLC program to to shut down the machine if it goes too high/low, I have a timer set up for start ups so it will not stop the machine. While running the motor load % is jumping up and down and sometimes reads wrong for several seconds on the PLC and HMI, but stays steady on the drive, currently have a 10 second timer set up to account for this but sometimes this is not enough. If you watch the HMI the Load % may be jumping from 15-40%, but on the drive display it is saying 40%. I have tried changing the communication baud rate from 4,800 up to 19,200 with no luck. Have also tried to add timers to only read the v-memory location every few seconds. with no luck. I am not sure what to adjust or how to fix it.

    Thanks,




  • #2
    It could be the drive display is simply smoothing the displayed number so the motor is fluctuating but the display doesn't show it. All AC motors slip as they are running, and loads can change a good amount across each rotation depending on the load they are connected to. It honestly wouldnt surprise me to see a fluctuation between 15-40% on a motor not tuned well for the application. Perhaps you should try tuning the drive more and see if you can get the fluctuations to tone down?
    Last edited by MikeN; 11-18-2019, 03:05 PM.

    Comment



    • #3
      Mike,

      I will try that.

      Here is a video of the HMI

      https://superatv2-my.sharepoint.com/...CttkSg1QsDTMbw

      Comment



      • #4
        I checked the voltage and amps at the motor and they are not fluctuating at all, so it has to be some type of communication or refresh issue. I got around it by calculating the load in the PLC program.

        Thanks for the help

        Comment

        Working...
        X