Announcement

Collapse
No announcement yet.

stepper motor suddenly slow

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • stepper motor suddenly slow

    I have a real head scratchier. I'll start with the background information.

    I have a do-more PLC with 3 h2-ctrio2 modules. This is an old setup from a gantry system that we scrapped. The goal is to run 2 stepper motors at independent speeds proportional to the speed read on the encoder. I'm using the dynamic velocity instruction with the result of a math box as the speed. It re-calculates every time it sees a change in the speed of the encoder. I set it up using just one motor to start, and it worked perfectly. Satisfied that everything else would be just as simple, we mounted the panel and the motor, and I wired them up again. Now, the motor is connected using 4 spade connectors and a length of 4 lead wire.

    Here's where the trouble begins. The motor failed to operate as it did before. It would move only at VERY slow speeds, and only in one direction. Suspecting the wiring, I checked the connections and cross checked with the documentation. All good. I began to suspect the motor, so I changed the motor. No change. I became suspicious of the amp. I altered the program to output to the second module as well and connected to the corresponding amp. No change.

    Now, here's where it gets really weird. In a fit of desperation, I wired a THIRD motor directly to the first amp and it worked properly again! Convinced that I must have had a bad connection, I carefully wired this third motor to the extension leads one at a time, and tested the motor after changing each connection. It continued to work, so I proceeded to mount the motor into place (with the wires still firmly connected) ..... and it failed. Same behaviour. Very slow speed, and only one direction.

    In an attempt to recreate my brief success, I grabbed one of the original two motors and wired it directly into the amp as before, and it failed as well. I'm at a complete loss. I don't understand how this is happening when nothing changed. At this point, I've tried every combination of motor and amp, quadruple checked the wiring from the modules to the amps, verified the powers supplies are working correctly, brought the acceleration parameters way down, and even tried using higher and lower currents. NOTHING! I'm legitimately starting to believe in gremlins.

    FYI, the PLC, motors, and amps were all working as recently as a month ago. I'm starting to suspect my program, though it's so simple, I don't see how it could be.

    Sorry for the long post, but any ideas at all would be greatly appreciated.

    Edit:
    here's the program. Conveyor_pct is R0 which is a touch screen input, as is C0.

    Click image for larger version

Name:	Capture.JPG
Views:	65
Size:	123.9 KB
ID:	127713
    Last edited by JLG; 01-15-2020, 11:34 AM.

  • #2
    Could your wiring on the encoder be loose and thus causing the velocity being read to be wrong/erratic?
    Perhaps as a test do not base your speed on the encoder, but enter a static, hardcoded value instead and see if it runs.


    Also, gremlins are real.

    Comment


    • #3
      I tried that once and it didn't change anything. I'm going to do another test using jog instead of dynamic velocity and see what happens

      Comment


      • #4
        May have found the problem. It looks like they was a small fray on one of the 24VDC wires to the module causing a short. Not sure why it worked those few times, but hopefully it keeps working this time.

        Comment

        Working...
        X