Announcement

Collapse
No announcement yet.

DL06 Serial/Ethernet

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • mdawg27265
    started a topic DL06 Serial/Ethernet

    DL06 Serial/Ethernet

    I am currently trying to make an ethernet drop to a DL06 Controller and using DirectSoft 5 (v5.3).
    First and foremost, I have no available slots for an ECOM on the DL06, and a fellow engineer gave me a serial/ethernet converter.
    The converter is a B&B Electronics ESR901.
    I am able to connect to the ESR901 via ethernet (straight to it via crossover as well as via Wi-fi).
    I am able to connect to the DL06 from my PC, so its comms are verified.
    When I connect my D2-DSCBL from the ESR901's DB-9 port to Port 1 on the DL06, I am unable to connect. All three devices are DTE, and I am using default K-Sequence 9600, 8, Odd, 1, None serial parameters.
    I've mapped (in turn) virtual COM ports 254, 16, and 8 to the ESR, as well as enabling them in DS500.INI, however I am still not able to connect to the PLC from the DirectSoft Link Editor.
    I hope I'm missing something simple and one of you can help me.
    Thanks in advance.

  • plcnut
    replied
    Originally posted by Mike@Forshock View Post
    PLCNUT: This is not the OP question, different poster
    Sorry Mike.
    I missed that

    Leave a comment:


  • Mike@Forshock
    replied
    PLCNUT: This is not the OP question, different poster

    Still think is timeout related, looking through Host Engineering most adjustments are only for ECOM. I have not programmed a unit over cellular or slower networks, but have had no issues with a Lantronix UDS serial server.

    Leave a comment:


  • plcnut
    replied
    Originally posted by Mike@Forshock View Post
    Why are you not using the ECOM100?
    The OP posted this:
    First and foremost, I have no available slots for an ECOM on the DL06, and a fellow engineer gave me a serial/ethernet converter.

    Leave a comment:


  • Mike@Forshock
    replied
    Most likely is timeout related.
    Why are you not using the ECOM100?

    Leave a comment:


  • stevejfrank
    replied
    elbertakibler,

    I am trying to connect to a DL06 using a Cradlepoint (Serial Redirector). I can connect to the remote port using a virtual com port without issue. Telnet and putty work just fine.

    When I return to create a new link using DS5 the unit is not able to connect. I see the com lights on the DL and the serial to usb connected to the cellular modem illuminate with RX and TX traffic. I can monitor the com port and see that hex data is passed back and forth, but that is as far as I can get. Wireshark isn't of much help it shows the same.

    It looks like the DL link editor is sending 4b2105 and the PLC is responding with a variety of the following:
    2105
    21
    06
    04

    Any direction you can provide would be greatly appreciated.

    Steve

    Leave a comment:


  • elbertakibler
    replied
    Testing Serial Connections

    I use this method to test Cellular Modems that have serial to IP converters built into them: http://www.putty.org/

    connect laptop using RS232 Straight through cable to cellular serial port
    start putty on laptop
    connect com1 serial connection (make sure hand shacking is off)

    start putty of remote computer
    select telnet use static ip of modem and port that you have configured such as 502

    NO FLOW CONTROL

    you should be able to send and retrieve data

    IE: type a string of data --> hit enter --> data should echo onto 2nd line


    Wire shark is also valuable for testing communications.

    Cheers!

    Lee

    Leave a comment:


  • Mike@Forshock
    replied
    Just like some USB converters have issues, ethernet virtual ports may have the same issue. That being said, I have used the Lantronix UDS2100 successfully.

    http://www.lantronix.com/device-netw...s/uds2100.html

    Leave a comment:

Working...
X