Announcement

Collapse
No announcement yet.

D4-454 Communication Modbus RTU - Problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Gudmundur Ben
    started a topic D4-454 Communication Modbus RTU - Problem

    D4-454 Communication Modbus RTU - Problem

    Hello, I just updated a broken D4-450 CPU with the new D4-454. After the replacement I'm not able to communicate with devices on Modbus RTU. I'm using port 1 wired as RS422, 9600 baud with no parity. I get no error on the port SP113 and both the RX and TX lights are blinking as long as the modbus device is online. Still I get no values from the modbus device.

    Best regards

    Guğmundur Ben

  • bcarlton
    replied
    Not exactly the same CPU but I often saw both lights blinking but no response when the wire pair was swapped.

    Leave a comment:


  • Gudmundur Ben
    replied
    Thanks for your response franji1. I had already configured the port in setup secondary com port as it was in the previous (D4-450) CPU. Also it looks funny that the TX/RX lights are blinking while the serial bus is connected but if I pull the power from one of the Modbus devices I get less blinking. I would assume that it was an indication of comunication but I dont get anything as a response to my requests, not even a zero.

    Leave a comment:


  • franji1
    replied
    Unless you wrote ladder logic to configure the port, you have to configure the serial port using DirectSOFT on new hardware. Sadly, the serial port configurations are not part of the project file (unless you have special ladder logic that does that).

    Leave a comment:

Working...
X