Announcement

Collapse
No announcement yet.

Productivity 1000 mapping Fanuc I/O over Ethernet IP - Invalid Segment Problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts


  • Productivity 1000 mapping Fanuc I/O over Ethernet IP - Invalid Segment Problem

    Hello,

    Before starting this thread I searched all over the internet and called customer service of both Automation Direct and Fanuc but no one could figure out how to solve this problem.

    I've Productivity 1000 and Fanuc LRMate 200iD with R-300iB controller.
    Both devices have IP and I'm able to ping them.

    Coming to setting up Input/Output Instances in PLC I tried every possible setting to make it work but this Invalid Segment problem won't go.

    I have attached Screenshots of current settings on Ethernet I/P on plc using EDS File provided by Fanuc

    Message set on Slot 1
    Input Instance I've
    Delivery Option Unicast
    RPI 32
    Assembly Instance 101
    Message Size Range 1- 500 (This is greyed out)
    Message Size from Array Bytes =2
    Data type Integer 16 bit 1D Array
    18 elements (Because I have UOP IN=18)
    Number of elements =1

    Output Instance I've
    Delivery Option Unicast
    RPI 32
    Assembly Instance 101
    Message Size Range 1- 500 (This is greyed out)
    Message Size from Array Bytes =2
    Data type Integer 16 bit 1D Array (20 elements) (Because I have UOP IN=20)
    Number of elements =1

    Config Data is Greyed out and unchecked

    I've also tried using Generic Client and changing Data Types. No matter what I do I am not able to fix this problem.

    On the robot side I've UOP In =18 on Rack 89 Slot 1 Start 23 Status Active and UOP Out =20 on Rack 89 Slot 1 Start 21 Status Active
    Under Ethernet I/P I've Connection Type as ADAPTER Set to True and Status Online

    If anyone with their experience and knowledge can help me.

    Please and Thanks
    Shan
    Attached Files
    Last edited by shan1727; 12-08-2018, 02:21 PM. Reason: Added Tags


  • #2
    should not make a difference, but enable routing. will turn the plc into a router, but maybe will work.

    I believe that either fanuc end is down or your message is discarded due to wrong format. for some reason, whatever the plc tries to send never reaches or never gets through.
    the fanuc documentation should tell how to check that fanuc accepts ethernet comms and how to check it.

    the ethernet communication is based on client-server. you need a form of protocol, like the modbus for example.

    if you just configure to send, try a short ladder to send a message on a different port first. it should give you a timeout error or server down. then try the right port. if it gives you the same message, then the server on fanuc might be down.

    then try to make sure you format the message for fanuc to understand it. try the simplest message possible.

    if nothing works, then try to find a terminal app so you could connect to fanuc from pc. see if you can get through that way.

    I have a vfd that says rs485 and whatever I tried, won't connect. people claim success, but I gave up. won't say I tried everything, but is just not worth the nerves. ultimately, if that machine needs to run, maybe you should consider investing in either testing tools or software or interface. hope this helps.

    Comment



    • #3
      Thanks for the help.
      I made it work by enabling the CONFIG DATA when setting up the Ethernet Client.
      The Fanuc documentation says not to use CONFIG DATA option and even their EDS file has that option greyed out.
      I watched few videos on how to setup eth/ip comm and they had config data unchecked.

      Now I am in a state where I want to send values to the robot Group In using PLC but not sure how can I, do anyone has any idea what run inst I can use?

      I've successfully mapped DI, DO, UOP In/Out, Group In/Out separately and can control them with PLC except for Group In/Out.

      Comment

      Working...
      X