Announcement

Collapse
No announcement yet.

Productivity 1000 RS-232 communication with Integra/Calamp DataRadio

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Productivity 1000 RS-232 communication with Integra/Calamp DataRadio

    We have installed 6 Prod 1k PLCs communicating via the RS232 port (Modbus RTU, 2400, No Parity, 8, 1, RTS Off) to the Integra Dataradio VHF radios which transmit to a repeater (using DOX not RTS) to monitor data and communications, initial installation works fine for a time period then the communication appears to fail. Radios are troubleshot for faulty feedline equipment, etc, any issues resolved, still no communication to the repeater. Wipe and reload the PLC, no immediate change; the communications usually start working on their own for no rhyme or reason. One thought was there could be an overload of data within the PLC causing the data string to be too long, why we tried wiping and reloading. Currently we have 4 out of 6 communicating, had 2 fail yesterday that resolved themselves.

    Any ideas?

    Prod1k Pinout to Dataradio Pinout

    1 GND TO 5 GND
    2 +5V not used
    3 RXD TO 2 RXD (output from integra to DTE; DTE being the device plugged into the com port, in this case Prod1k)
    4 TXD TO 3 TXD (input from DTE to integra)
    5 RTS not used
    6 GND not used
    1 DCD
    4 DTR
    6 DSR
    7 RTS
    8 CTS
    9 RI

    Again, we have had data communication, one site has been operational since Nov '18, its first comm fail was yesterday resolved this morning...

  • techme
    replied
    1) What are the TX/RX lights doing on RS232 port of the CPU in this state?
    2) Have you tried to monitor or put counters on the port status bits? (Heartbeat Timeout, Port Buffer Full, Port Ready bit)
    3) Have you tried to delete the value you have in the Modbus Character Timeout? ( If left blank it will calculate the timeout needed for baud rate selected) You currently have it set to 1000 msec. At a 2400 baud it should be about 7 ms.

    Leave a comment:


  • jfrye
    replied
    Request you go online with one of the CPU's and create a system report. You can post to this thread or if needed contact our technical support team so we can begin a trouble ticket on this issue.
    I have attached 3 system reports from 3 different sites, all of which were in serial comm fail.
    Attached Files

    Leave a comment:


  • jfrye
    replied
    Have been out of the country, will try this soon hopefully.

    Have another question about the same application; attempting to write a floating output from the repeater to the Prod 1k using the repeater PLC's modbus transfer function. IO addresses are correct but no data is being transferred from the repeater to the Prod 1k. Using the read counterpart modbus transfer function we are able to read data from the Prod 1k via the repeater. Not sure where to go from here, we tried using a MRX function but that sets the Prod 1k to be the master, which would not work with the repeater being the master.

    Leave a comment:


  • P3K_ADC_Eng
    replied
    Request you go online with one of the CPU's and create a system report. You can post to this thread or if needed contact our technical support team so we can begin a trouble ticket on this issue.

    Leave a comment:

Working...
X