Issue started about month ago, where webserver and remote connectivity to the panel stopped few minutes after C-more startup.
Worked fine for about a year with 6.21 firmware and having problems with the same firmware.
I've upgraded to 6.43 last week, without resolving the issue.
Panel works fine, and I see no webserver, ftp server or remote connect errors in the Error list. Yesterday I saw 2 errors: PLC-009 and PLC-007, but these are modbus comm issues. Modbus RTU over RS485 to two Click PLC's works fine as is Modbus TCP to ventilation unit (same network as webserver, ftp server and remote connection)

Ping to the panel works all the time. Telnet to ports 80, 21 and 11102 from the same network as HMI works for few minutes, then stops and only HMI restart helps to bring it back.

This started to happen month ago, when I tried to configure email sending to gmail and ftp server, which wasn't previously enabled. I've also changed from 1G sdcard to 16G sdcard, where some values are stored from few graphs.

So far I've tried to disable email, and ftp server, to bring back web server and most importantly remote connectivity without success.

Is there some way to diagnose, what is going on with servers on that Windows CE HMI?