Announcement

Collapse
No announcement yet.

Can't get click PLC to make a TECO L510 drive work via RS-485

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    I got a decimal value of 3 for exception error. I did not convert to hex. This is before I did the subtraction. After, which now makes it 2501, I still get a decimal value of 3 for the exception error.


    UPDATE: I figured out my issue. I had the wires in the wrong spot on drive side. The book showed the wiring incorrectly.
    Last edited by DenR; 03-23-2020, 12:30 PM.

    Comment


    • #17
      exception 3 Illegal data value - Not accepted by slave.
      https://en.wikipedia.org/wiki/Modbus...tion_responses


      Check param 09-01 = 0

      I would attempt to read a register value before writing.

      I would also experiment with the data that you are sending - try swapping - the 03E8H to E803H -- since the Send instruction does not support byte swap in HEX addressing.

      Comment


      • #18
        Originally posted by kewakl View Post
        exception 3 Illegal data value - Not accepted by slave.
        https://en.wikipedia.org/wiki/Modbus...tion_responses


        Check param 09-01 = 0

        I would attempt to read a register value before writing.

        I would also experiment with the data that you are sending - try swapping - the 03E8H to E803H -- since the Send instruction does not support byte swap in HEX addressing.


        It was faulty wiring. Had the wires on 7 and 8, but it was suppose to be on 1 and 2 pins on the drive side.

        Comment


        • #19
          Hey, thanks for the resolution.

          Comment

          Working...
          X