Announcement

Collapse
No announcement yet.

DL06 with H0-ECOM, DS5 won't connect over internet

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • DL06 with H0-ECOM, DS5 won't connect over internet

    Using the latest DS5 & updated firmware on the DL06 & ECOM module. To be clear, this is a H0-ECOM and not the ECOM100 version.

    Goal is to be able to monitor PLC over the internet using DirectSoft, and perhaps upload program updates.

    Connecting to the ECOM within the local network is successful and works great via DS5 or NetEdit3.

    Have been successful in connecting to the ECOM100 at Host Eng, via internet as per FAQ0016.

    Have UDPPortNumEnable=1 in the .ini file, but in DS5 there is no place in the dialog box to put in a port# as indicated in method #2 of FAQ0016, so I don't know how I would go about connecting to any PLC on a port other than the default. This is not a concern since I only ever have 1 PLC on any outside network, just giving you the info FYI.

    Connecting from the outside via Internet, having no luck.

    Have my router set up to route port 28784 to the ECOM module. ECOM module local IP is 192.168.0.2 and can access it via this IP on the local network. When trying to connect by putting in the non-local IP in the link configuration (then hit "Auto") I get a "Transport protocol error".

    I can't confirm this anywhere, but is is possible that the ECOM100 is required for connection via internet? Or what else can I try?

  • #2
    A standard ECOM should work fine.

    You cannot use Auto to set up a remote link, it must be done manually. The discovery packets will not be passed by most ISP routers.

    Other than the manual setup, you will probably need to set the link timeout higher than the default values that Directsoft gives.

    Open a command window and ping the remote ECOM. Take the number that is returned in ms and multiply it by 3 and add 1000ms. Put this in the timeout window in your link setup.
    If you have an urgent issue, please contact AutomationDirect's Technical Support team.

    AutomationDirect.com Technical Support: 1(800) 633-0405 or (770) 844-4200 Email Tech Support

    Comment


    • #3
      Thank you,
      Max ping time is 66ms. Timeout I had set at 1000ms.

      One thing I noticed:
      ;UDPPortNumEnable=1 in the .ini file used to have a semicolon ahead of it. I had deleted the colon and then restarted DS5. Upon trying after that, I noticed no difference in the "Configure Link" interface. Now that I was double-checking the advanced settings, I see there is an added line for "UDP Port Number" which wasn't there before. Did the semicolon cause the DS5 startup to overlook that line?

      Anyways, even after that change there is still an error. My settings:
      PLC tab - 06 series, 06

      Port tab - Devices=ethernet, Transport Protocol=UDP/IP, Node Address=IP, IP=10.13.13.51 (the WAN IP of the router connected to the ECOM)

      Protocol tab - Protocols=ECOM, Advanced Settings=Retries 3

      The ECOM is set up with it's local IP of 192.168.0.2

      The router is directing port 28784 to the ECOM.

      Hitting "Accept" returns the "Link Failed!" error.
      Hitting "Auto" returns the "Transport protocol error"

      Is there any other info I can provide?

      Comment


      • #4
        Problem solved!

        It was a port forwarding issue with the router. It was set up to forward the correct port to the correct IP, but on the "private" side the port was not specified. Apparently the IP & Port on the LAN side needs to be specified for the ECOM.

        By the way, the line in the .ini file having the ; ahead of it does render it "off" so:

        ;UDPPortNumEnable=1 or UDPPortNumEnable=0 means it's OFF

        but

        UDPPortNumEnable=1 means it's ON

        however, the UDP port enable did not affect whether it would connect after I had it working - apparently if I were using a non-default port number this would be an issue, or the UDP port was set and remained set for that link even I disabled UDP port in the .ini file.

        Comment


        • #5
          That setting only affects ECOM100's.
          If you have an urgent issue, please contact AutomationDirect's Technical Support team.

          AutomationDirect.com Technical Support: 1(800) 633-0405 or (770) 844-4200 Email Tech Support

          Comment


          • #6
            Is port 28784 the standard port to use to for DS5? Im trying to do a similar thing. I have two HMI's and one ECOM100. How do you tell DS5 to use a given port?

            Comment


            • #7
              Its the default port, I don't think there's a way to change it in DS5.

              If your PC (with DS5) & the ECOM are not on the same LAN, you may need to set up the router (where the ECOM is) to forward port 28784 to the ECOM. If you are on the same LAN, then the ECOM would have it's own IP and forwarding isn't necessary.


              EDIT: You can change it in DS5, if port num enable is ON (as described in previous posts), search for it in the FAQ section at hosteng.com
              Last edited by dieselvette; 09-10-2010, 08:44 PM.

              Comment


              • #8
                I have it all on the same network. however I have all the control components on a AD Unmanaged Switch that is then tied to the DSL router. I know that its working at least half way correctly because I can connect with every part (2 HMI's and 1 ECOM100 In an DL06) how ever when i try to link in from the outside of the network (using the static IP address it doesn't work. The system is installed in a home the ISP is Quest. the router is a Auctiontec Q1000. I called quest and they walked me through one way of opening the port but it didn't work. They said that the router isn't seeing the ECOM100. it doesn't show up on the active device list but I can ping it and connect to it with DS5.

                Any ideas? I am not able to release the ip address for any one on here... sorry.

                Comment


                • #9
                  I will have to do this again soon so hopefully I can confirm later, but I think that you have to use NetEdit3 to set the local IP in the ECOM module, and then use a corresponding local IP in your router port forwarding. I'm not sure why/if the ECOM needs to know it's IP, but I know that I have been successful and it involved setting up the ECOM properly first.

                  The router won't recognize the ECOM & assign it an IP, perhaps because it doesn't send out packets like other devices for identification. So maybe you need to get the MAC address & IP in the ECOM and forward port 28784 to that?

                  Perhaps an expert can clear this up for us.

                  Comment


                  • #10
                    Ok now i know it the router, If i set the DMZ to the PLC or any other device for that mater i can get in, but not using port forwarding.... ideas?

                    Comment


                    • #11
                      See post earlier 34403, "Problem solved".

                      Is it an issue to just use the DMZ then? Port forwarding may be a little more secure, but if the ECOM is on a DMZ who can really hack it without using the PLC-specific protocol?

                      Comment


                      • #12
                        Security by obscurity? But then again port forwarding is in the same level of security. A VPN can be a much more secure access.
                        thePLCguy

                        Bernie

                        Comment


                        • #13
                          Yep, nuff said

                          Comment


                          • #14
                            Originally posted by Do-more PE View Post
                            A standard ECOM should work fine.

                            Other than the manual setup, you will probably need to set the link timeout higher than the default values that Directsoft gives.

                            Open a command window and ping the remote ECOM. Take the number that is returned in ms and multiply it by 3 and add 1000ms. Put this in the timeout window in your link setup.
                            I wanted to drop a line that this was only change we needed to correct a "Transport Protocol Error" and allow the vendor remote access over a Tosibox Lock 150 to our system, with a D2-260 CPU. Default value was 50ms which was way too short (ping was showing ~800 ms).

                            Comment

                            Working...
                            X