Announcement

Collapse
No announcement yet.

Router Setup with H0-ECOM100

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts


  • Router Setup with H0-ECOM100

    This is my first foray into setting up an ecom module into a dl-06 plc. All i need to be able to do is update the program remotely in the plc and c-more ea7-s6m. I have a d-link ebr-2310 rev.b router.

    I'm a bit confused on what ip address I put into the port forwarding table in the router for the plc and c-more. There is also a selection for computer name. all the computers (including mine) show up in this drop down menu.

    I know that the c-more program update port is 9999 and the ecom is 28784. i can put this port in the udp or tcp field and it is my understading it goes into the tcp field.

    I have acquired a static ip address from my isp. This is to be used for the ecom module. do I put this address in the port forwarding table in my router? Or do I type in that address into my web browser when wanting to talk to the plc or c-more?

    The c-more panel has a private ip of 192.168.1.101 The public ip has not yet been assigned as the clients IT dept. is going to provide this as they will be accessing the panel remotely to view status.

    I dont understand how i assign a public ip address to the ecom.

    I just need to understand the sequence of ip addressing and ports and where to enter them. I have read all the faq at host eng. and multiple articles on the web. i know this is basic stuff but I am just not getting a grasp on it.


  • #2
    For port forwarding, all of the equipment must reside behind the router on the private network. Let's say the customers private network is 192.168.1.xxx.

    He has set the private IP address of his router to 192.168.1.1.

    The Cmore is set to 192.168.1.2 and the ECOM module is set to 192.168.1.3.

    In the port forwarding table, he would configure it like so:

    Code:
    Device       IP       Port     TCP/UDP
    Cmore   192.168.1.2   9999      TCP
    ECOM    192.168.1.3   28784     UDP
    Now to access the device outside of this network he would need the public IP address of the router. This is the IP address that he would put in the Cmore software and Directsoft in order to connect to the devices through the router. The router will take care of pushing the packets to the correct Private IP address since it know what the IP address is associate with each port through the port forwarding table.
    If you have an urgent issue, please contact AutomationDirect's Technical Support team.

    AutomationDirect.com Technical Support: 1(800) 633-0405 or (770) 844-4200 Email Tech Support

    Comment



    • #3
      my router will not accept an address of 192.168.1.101. it says it must be a LAN address.

      Also, what do I do with the assigned static ip address for the Ecom? why did I need this from my isp?

      Comment



      • #4
        The only reason you would need a static IP would be if you were to stick the ECOM out on the Internet directly and not behind a router.

        If the Router won't accept the address then you are probably trying to put the address in the box for the external IP address that is shown to the Internet, not the internal Private IP address which is for the Private Network.

        Post some screenshots of your router setup and I may be able to be of more help since I don't have a D-Link EBR-2310 available.
        If you have an urgent issue, please contact AutomationDirect's Technical Support team.

        AutomationDirect.com Technical Support: 1(800) 633-0405 or (770) 844-4200 Email Tech Support

        Comment



        • #5
          Ok, thanks. So then I dont actually need a static ip since I am going to access the ecom from my workstation going through our router.

          Screenshot attached
          Attached Files

          Comment



          • #6
            when i open net edit the software does not find the ecom module when I do a scan for modules. I have version 3.7 of net edit. I have no code in the plc for the ecom module as tech support told me i do not need it.

            Comment



            • #7
              In the left hand field that says name, give the entry a name such as Cmore.

              Below that, you woule enter the Cmore's IP address.

              On the right for the TCP port you would enter 9999.

              Leave the schedule for Always.

              Check the box on the far left to enable the rule and click Save settings.

              Do the same thing for the ECOM.

              As far as troubleshooting why you can't see the ECOM, I am going to suggest calling or emailing technical support. There are just too many things that could be causing it to try to troubleshoot here in the forum.
              If you have an urgent issue, please contact AutomationDirect's Technical Support team.

              AutomationDirect.com Technical Support: 1(800) 633-0405 or (770) 844-4200 Email Tech Support

              Comment



              • #8
                So I found the ECOM. No problem. I run Windows 7 and had to turn off the firewall. I configured the ECOM with a module id of 1 and an ip address of 192.168.0.5 as my computer has an ip of 192.168.0.111. It is my understanding the first 3 octets must match. True? Or should I be using an ip of 10.?.?.?

                Problem is when I create a link i get error 10051. Win 7 does not support IPX. So I went into firewall and opened up a permissive on port 28784 UDP for the ECOM module. Or do I select TCP? Which is it? Regardless neither UDP nor TCP selection in firewall made a difference.

                I still get error 10051 when creating the link. Aughh! So close....

                Comment



                • #9
                  You need to select UDP and use the IP address option when creating your link.
                  If you have an urgent issue, please contact AutomationDirect's Technical Support team.

                  AutomationDirect.com Technical Support: 1(800) 633-0405 or (770) 844-4200 Email Tech Support

                  Comment



                  • #10
                    I did that and no go.

                    Comment



                    • #11
                      I went through alot of settings with tech support over the phone. I have set my LAN to the top of the list, turned off firewall, changed user account settings to least notification and I still get ExError 10051 which is an IPX error. IPX is not supported on Win 7. If I am not selecting that as the protocol in NetEdit then why do I get the error? Where in my OS could it be trying to use IPX when it does not even exist?

                      I select ip address in link editor, udp and so on. I really need to get this sorted. Any help greatly appreciated.

                      Comment



                      • #12
                        That error can also mean that your network card is disabled or that you don't have the proper protocols installed for the network card.

                        In your case you need to have TCP/IP protocol installed and there needs to be a valid address assigned to the network card.
                        If you have an urgent issue, please contact AutomationDirect's Technical Support team.

                        AutomationDirect.com Technical Support: 1(800) 633-0405 or (770) 844-4200 Email Tech Support

                        Comment



                        • #13
                          I have successfully linked up to the ECOM over our network.

                          The C-More I am not having any luck with.

                          Comment



                          • #14
                            i have everything working now. Thank you for your assistance

                            Comment



                            • #15
                              I need the router setting advice "d-link dir-632"

                              I have the same problem with router.
                              The public port and privite port have to be setting "?????".
                              Please tell me how to set both of them.
                              And I need to connect 6 pcs PLCs in the router.
                              (1 pc h2-ecom and 5 pcs h0-ecom)
                              Attached Files

                              Comment

                              Working...
                              X