Announcement

Collapse
No announcement yet.

Configuring Analog I/O setup on Click PLCs

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts


  • Configuring Analog I/O setup on Click PLCs

    Hello. This is my first time working with the Click PLCs. I'm using a model C0-02DR-D processor with several I/O cards. My question has to do with configuring the built in I/O on the processor.

    When I try to change the output from the 0-5 volt configuration to the 4-20ma configuration it doesn't take in the processor. It shows up in the system monitor that my output should be at the corresponding mA value via scaling to what I have in the assigned register, but the output is still utilizing DAV channel (i.e. the System monitor says that I should be outputting 10 mA on DAI1, but I'm actually measuring 2.5vDC on DAV1).

    I'm sure there is some procedure I'm missing on synching the PLC to the configuration in the IDE, but I can't figure it out from the manuals, from the way they are written it seems like the changes should happen hot.

    So far I have tried the following:

    1. Switching processor mode to stop prior to making changes.
    2. Downloading project file to processor with configuration changes saved
    3. Rebooting the processor following the configuration change.

    Any help would be greatly appreciated,

    Thanks!


  • #2
    Did you change the wiring according to the diagram (page 2-49)? In the current mode ignore any readings on the DAV pins. They aren't used.
    Last edited by bcarlton; 03-15-2014, 09:50 PM.
    thePLCguy

    Bernie

    Comment



    • #3
      Thanks! That was the issue. I guess I'm just too used to cards that source their own loop power.
      -Vince

      Comment

      Working...
      X