Announcement

Collapse
No announcement yet.

Analog Outputs

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts


  • Analog Outputs

    Hi all!!!
    Im really new to AD and Im having some problems programming the analog outputs. I have a DL06 and a 4 AO module. The AO has to control a VFD from 0 to 100% in 4-20mA.
    Have been reading about the IBoxes, conversion between real, BCD and binary, but it will be VERY helpfull if someone can share some code to clarify and understand how this whole thing works.

    Thanks in advance and greeting from Argentine

    Damian


  • #2
    what are you using for the VFD speed input?

    Comment



    • #3
      Scott, Im not getting feedback from the VFD, because it is not necessary.
      I just have to send a velocity from the HMI but, how the PLC is used, Im not sure if the module is not working, or if my code is wrong.
      Here is a part of the code:

      ANLGOUT K0 K1 K4 K0 V3020
      LD V3040
      MUL K4095
      DIV K10
      BCD
      OUT 3020

      So, if I change from the data window, the value of V3020, the output should vary? No matter which value I enter, the current of the output do not go far from 6mA.
      Think Im very lost!!

      Thanks!!!

      Comment



      • #4
        LD V3040 --- this better be a BCD value (I'm guessing 0 - 10) because ...
        MUL K4095 --- this is a 'BCD' type instruction and ...
        DIV K10 --- this also is a 'BCD' type instruction
        BCD --- so this should be unnecessary
        OUT 3020 --- then placing the 0 - 4095 BCD value here should affect the module's output

        Then there is always the question on the correctness of the wiring.
        thePLCguy

        Bernie

        Comment



        • #5
          bcarlton, thanks for your explanation.
          My problem is that I can not understand WHERE or HOW, once I do all the maths, I assign that calculated number to the analog output itself to see the 4-20mA varying.

          Thanks!!

          Damian

          Comment



          • #6
            Editting my comment, I see you already posted your set up logic, and it looks correct.

            Did you do a power cycle after programming the analog set up Ibox?
            Is the PLC in "run" mode?

            The "OUT V3020" box at the end of your math instruction should be putting a 0-4095 value into vmemory location V3020, which should be the memory location that the analog output module in slot 1, channel 1, is looking at for an output value.
            Last edited by Bob S BN; 10-02-2015, 10:59 AM.
            Bob

            Comment



            • #7
              Dear Bob,
              I have donde all that you said, but still no change on its behaviour.

              How I said before, maybe the 4 ch AO card is not working at all.
              But sounds rare to me that I can obtain like 6mA going out of this output, frecuently AO not working are opened circuits.

              Im getting a little freaky about this!!

              Comment



              • #8
                Can you please verify you have it all wired correctly, according to the manual found here...

                http://www.automationdirect.com/stat...0optionsm.html

                EDIT: How are you testing and finding the 6ma? Please confirm what wires/terminals you are attaching your meter to. You are aware that you need the ma meter wired in series with the analog circuit loop, right?
                Last edited by Bob S BN; 10-02-2015, 11:50 AM.
                Bob

                Comment



                • #9
                  Solved

                  People, I finally make it work, just for someone dealing with the same thing, I made all my maths with instructions for BCD, that is to say.....MULD, ADDD, etc.
                  Thanks to everyone!

                  Damian R

                  Comment

                  Working...
                  X