Announcement

Collapse
No announcement yet.

Do-More files won't open from the folder

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Do-More files won't open from the folder

    First I realize version 2.3 is out and I'm updating now but this has a been an issue for a long time (since 1.4 I think or perhaps I first noticed it in 2.0...) and I don't expect it to get solved by the update.
    I have .dmd files associated with DmDesigner.exe in the Bin directory of version 2.1. My .dmd files show the DMD 2.1 icon. When I double click them, I get a message saying 'Unsupported File Extension ".dmd" '. I right click on a .dmd file and select "open with", navigate to DmDesigner.exe and select it and I get the same message. If I open DmDesigner.exe and ask it to open a file and choose the .dmd file, it opens just fine.
    I've never seen this behavior before and I'm curious if anyone else has run into it or has a way to solve it. I'd really like to be able to open a file from it's location instead of having to open DMD and use the open file dialog. Am I supposed to use a different exe to autoopen .dmd files? I couldn't figure out which it might be and since they open fine from inside DmDesigner.exe, I would expect associating the file with that exe to work like it does for all other programs. Thanks in advance.

  • #2
    I get the same issue - we will look at it.
    Not sure how any previous version would have worked, but regardless, it should be able to launch a project file via the "command line"
    There are 10 kinds of people in this world, those who know binary, and those who do not.

    Comment


    • #3
      How to get it to work in WinXP and probably Win7 has been posted before here or on Host's forum. All I managed to do in Win10 with the right click file association was compact my desktop icons into a useless mess again. But I did get it changed in my registry just now from v2.1.4 to 2.3.2 with this key:

      [HKEY_CURRENT_USER\Software\Classes\dmd_auto_file\s hell\open\command]
      @=""C:\\Program Files (x86)\\Do-more\\Designer2_3\\Bin\\DmDesigner.exe" %1"

      But in the registry the line should look like this:

      "C:\\Program Files (x86)\\Do-more\\Designer2_3\\Bin\\DmDesigner.exe" %1

      And this one:

      [HKEY_USERS\S-1-5-21-51019888-1264289938-3436860795-1001\Software\Classes\Applications\DmDesigner.exe\ shell\open\command]
      @=""C:\\Program Files (x86)\\Do-more\\Designer2_3\\Bin\\DmDesigner.exe" %1"

      Note the missing double quotes around the %1 - Microsoft insists on adding them and that breaks it. They can't leave desktop icons alone either.

      And the other thread:

      https://forum.automationdirect.com/f...ming-questions
      Last edited by Mike Nash; 06-29-2018, 05:27 PM.

      Comment


      • #4
        I think I have a similar experience. Someone posted a program example on here. I down loaded it and unzipped it. I clicked on it and I get that message you are talking about. When I try to change association it shows version 2.2 and wont let me change it. Is this what you are talking about? But if I open 2.3 and go to the file I unzipped, it works.

        Comment


        • #5
          Well there are a few things that are odd. Such as my files were associated with DM v1.4 and even after I "opened with" and set as default DM v2.1, the icon was still v1.4. To fix that I uninstalled old versions but that didn't solve the problem of the files not opening. The link Mike Nash posted is a thread that had a link to the host engineering forum which has a post by plcnut that had the solution that worked for me.
          http://forum.hosteng.com/index.php?P...&topic=1657.15

          Seems like the right solution assuming you're willing to edit your own registry. I have no idea why that step is necessary. I would think the "open with" dialogue would generally perform the steps, 1) open program, 2) run open file, 3) select file which is a set of steps that works just fine. But I definitely don't know enough about operating systems to really understand why that doesn't do what I'd expect it to. BobO made some mention of a security update which might allow this to work properly in future updates. Guess we'll see and just continue updating our registry on updates until then.

          Comment


          • #6
            The double quotes were being passed in to Designer EXE command line - they are now stripped out and it appears to work. The double quotes need to be included as part of the file association for proper handling of white space in the file path.

            This fix will be in our next release.
            There are 10 kinds of people in this world, those who know binary, and those who do not.

            Comment

            Working...
            X