No announcement yet.

Controlling stepper motor with a BRX PLC – BX-DM1E-10ED13-D

  • Filter
  • Time
  • Show
Clear All
new posts

  • Controlling stepper motor with a BRX PLC – BX-DM1E-10ED13-D

    I followed the example on Page 41-48 in Chapter 12 of BRX user manual to configure and test a high speed pulse output with a trapezoid profile but I can’t get my stepper motor running.








    Connect Y0 to STEP-

    Connect Y1 to DIR-

    Connect Y1C to -5VDC logic supply voltage of the stepper power supply

    Connect the +5VDC logic supply voltage to the STEP+ and DIR+ terminals of the drive

    Click image for larger version

Name:	wiring.JPG
Views:	435
Size:	222.5 KB
ID:	120695

    Ladder code:

    Just two rungs

    On rung 1 – C0 + AXCONFIG instruction

    On rung 2 - C3 + AXPOSTRAP instruction

    Click image for larger version

Name:	two rungs.png
Views:	307
Size:	220.1 KB
ID:	120696

    Click image for larger version

Name:	after triggering C0 and C3.png
Views:	299
Size:	533.3 KB
ID:	120697

    Note: the self test mode on the drive turns the motor twice in one direction and then twice in other direction so I think the stepper motor is fine.

    Any help would be appreciated.


  • #2
    Make sure Axis 1 is set to Pulse Output (and not virtual). Make sure you have Step/Direction selected in Axis 1 Setup (and not CW/CCW or Quadrature). Make sure Step IS Y0 and Direction IS Y1. Make sure your Jumper S3 is on 1-2 position on the drive for Step/Direction. Your velocity of 1000 Hz is going to take about 20 seconds to move -20000 steps.

    Whoever thought that "Enable" input designation up on the drive was NOT thinking at all. But nothing tied to the EN terminals looks right.

    I've never used the SureStep so I'm "guessing" here.
    Last edited by Mike Nash; 02-17-2019, 12:22 PM. Reason: Fixed comment about enable signal name.


    • #3
      Thanks for your response.

      The Axis/Pulse output and Jumper S3 were configured the way you mentioned.

      Click image for larger version

Name:	axis and pulse output.png
Views:	266
Size:	346.0 KB
ID:	120701

      And yes. The EN+ and EN- terminal are left unconnected because the enable function is not required here.


      • #4
        You can see that the axis itself did move based on .CurrentPosition. Toggling C3 off and back on it should go to -40000. If you have a scope I would check the Step signal. If only a meter, see if Step is about 2.5VDC during a move and either 5V or 0V (or close) when not moving.

        And make sure you are using terminal 1C on the Y outputs. 1C and 2C are isolated from each other.

        One other thought I had was whether you have Y0 or Y1 as an output elsewhere in the ladder or forced maybe. I don't know if that is even possible honestly.
        Last edited by Mike Nash; 02-17-2019, 12:25 PM.


        • #5
          Thanks Mike,

          Toggling C3 off and back it indeed goes to -40000.
          I checked the voltage between STP+ and STP- with a multi-meter. the value is 5VDC when not moving and stays the same 5VDC during a move. Does this suggest the drive has a problem?


          • #6
            I'm thinking it is wiring between drive, PLC and power supply. What you have in post 1 is right. But 1C to 5VDC common has to be the 1C just above Y0. Do you have the Y0 and Y1 LEDs showing activity?


            • #7
              That's exactly how it was wired. see the pic below:
              Click image for larger version

Name:	Y0Y1Y1C.png
Views:	247
Size:	251.0 KB
ID:	120711

              Both the Y0 and Y1 LEDs are on

              Click image for larger version

Name:	Y0Y1 LED on.JPG
Views:	250
Size:	185.5 KB
ID:	120712


              • #8
                Try Jumper S4 in the 1-2 position for 2 MHz filter. I'm not where I can 'scope the pulse train here. The max freq as shipped default on the drive is 150 KHz and the PLC can do 250 KHz. I don't recall what the step pulse duration is in Step/Dir and CW/CCW.

                In Quadrature it will be a 50% of output frequency. You could always try Quadrature to see if the drive can see the PLC Step signal, but you would have to disconnect Y1 and the drive would only go one way and maybe 1/4 the distance (not sure if it does cycles or edges in Quadrature.)


                • #9
                  I tried Jumper S4 in the 1-2 position but still no luck.


                  • #10
                    Without a way to view the signals going into the stepper drive from the PLC, I'm at a loss as to how to proceed. If all your connections are good, I'm not seeing anything else obvious. Hopefully you can wait out today and give Automation Direct tech support a call in the morning. Good luck!


                    • #11
                      Nice. Thank you Mike!


                      • #12
                        You're welcome. One last thought if you want to try it today - use the 24VDC powering the PLC for the power for the Step/Direction and PLC outputs. Just remove the 5V wires at the power supply and connect to the ZipLink board with the 24V power leads. Maybe we are just too far down at 5V. The PLC says it can operate there, but I don't know that for sure. The stepper drive inputs are OK at 24V.


                        • #13
                          I just tried using the 24VDC instead of 5VDC as you suggested and still unable to get the drive to run the motor. Thanks again


                          • #14
                            Just FYI, I just 'scoped Y0 on a BX-DM1E-36ED23 set for step/direction. The pulse width for the step output is 50% duty cycle of the output frequency, so any filter setting should have been fine at low speeds. I hope you get this sorted this morning.

                            Mine is a sourcing output and I don't have that series stepper drive here. I have been running a step/direction servo from this BRX recently.


                            • #15
                              This morning I switched the Jumper S3 from 1-2 position (STEP/DIR) to 1-3 position (CW/CCW) and reconfigured the Axis 1 Pulse output to: @Axis1 - Axis with CW/CCW pulse out - CW: Y0, CCW: Y1. With CW/CCW inputs, it makes the motor turn. Yeah, that's a good thing. However, still puzzled as to why this drive doesn't understand STEP/DIR signals?

                              Now I am thinking about sending the drive (STP-DRV-6575) back for a replacement....