Announcement

Collapse
No announcement yet.

This Warning is Driving me Crazy

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • This Warning is Driving me Crazy

    Just updated to 2.5 and also updated gate and loader to the latest. No warnings before the update. The problem is that I cannot find out what the error actually is so I can fix it. The loaded program is executing without any problems.
    Any help would be greatly appreciated.
    Thanks,
    Pat
    See Below:

    Click image for larger version

Name:	Annotation 2019-03-31 094927.jpg
Views:	167
Size:	49.2 KB
ID:	121652

  • #2
    There was a bug in previous versions of BRX that was not properly reporting I/O errors. That was fixed. We also did quite a bit of work to point the user to the problem...which I'm not seeing here. Fail.

    Most likely your analog input is reporting out of range. For a voltage input that would be an input value outside the configured range. For a 4-20ma, it's likely 0 current in.

    We'll figure out why you aren't getting better direction from DmD and will get it fixed in 2.6.

    Comment


    • #3
      Bob,
      Thanks for the quick response. The analog input being out of range makes sense since it is unused. Now I know this is a warning I can ignore.

      If I may make a suggestion. In the config of my BX-04ad-1 analog input module I can enable just the ports I am using. Adding this same functionality to the built-in I/O would allow the error trapping code to ignore the error if the port is disabled.

      Pat

      Comment


      • #4
        Originally posted by pdavitt View Post
        Bob,
        Thanks for the quick response. The analog input being out of range makes sense since it is unused. Now I know this is a warning I can ignore.

        If I may make a suggestion. In the config of my BX-04ad-1 analog input module I can enable just the ports I am using. Adding this same functionality to the built-in I/O would allow the error trapping code to ignore the error if the port is disabled.

        Pat
        Shouldn't need to. The default mode should be fine when not used. Can you confirm that it is set to voltage?

        Comment


        • #5
          Originally posted by BobO View Post

          Shouldn't need to. The default mode should be fine when not used. Can you confirm that it is set to voltage?
          Good catch. It was set to 4-20mA. I re-set it to 0-5V and the warning went away.

          Pat

          Comment


          • #6
            2.6 will definitely report on-board BRX analog input warnings with more detail.
            There are 10 kinds of people in this world, those who know binary, and those who do not.

            Comment


            • #7
              Originally posted by franji1 View Post
              2.6 will definitely report on-board BRX analog input warnings with more detail.
              Thanks. Or in binary: 01010100 01101000 01100001 01101110 01101011 01110011 :-)

              Pat

              Comment

              Working...
              X