Announcement

Collapse
No announcement yet.

h2-dm1e

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts


  • h2-dm1e

    Having trouble setting up the smtp server to send emails any thoughts or help


  • #2
    Some email providers, including many popular ones, use the 'POP before SMTP' authentication method, meaning that the server expects you to login as if you're collecting mail before sending any. This isn't a problem for Do-More, except when the POP and SMTP servers have different IP addresses. It used to be impossible to use those providers with Do-More, but now you can write to the other IP address from ladder in a way that I can't recall at the moment. If you are trying to use such a provider and haven't set up the second IP address in ladder, that might be your problem.

    Comment



    • #3
      I certainly appreciate your help and thoughts on my issue I was ready to start drinking.
      would you possibly have an example of how to write this code?

      Comment



      • #4
        I use Gmail for my Do-More emails and C-More emails. The BRX allows for secure email. So, I use smtp.gmail.com. However, the H2-DM1E does not support the SSL/TLS option. So, I have to use aspmx.l.google.com on port 25. This will only allow for Gmail recipients as your targets, though.

        Find GMail server info here: https://support.google.com/a/answer/176600?hl=en

        Make sure you have the routers LAN IP Address used in your Do-More’s Default Gateway Setting. Use the DNS Lookup instruction to find the IP Address for aspmx.l.google.com. I use Google’s DNS server 8.8.8.8 / 8.8.4.4. Within your Google account settings (not gmail settings) there is a feature in Privacy settings (or security settings) to allow for “Less Secure Apps.” This needs to be enabled. The example at the bottom of the Do-More Help Topic has a nice walk-through.

        Comment

        Working...
        X