No announcement yet.

Out of the blue.....COMM Errors.

  • Filter
  • Time
  • Show
Clear All
new posts

  • Out of the blue.....COMM Errors.

    Out of nowhere, comm errors, all of a sudden, on stuff, BRX has been reading and writing for weeks without any ssues.

    Only change...

    Slot 3 was changed from an 8 point relay module to a 16 point relay module. Yes of course, I downloaded the correct configuration.

    Not sure why this is happening.

    But when it is happening, all be it sporadically, C-more shows comm errors on the screen, but goes away after few seconds. However, I do not lose comms from C-more to the BRX during this time. In other words, I can still send stuff to it and get a response back, and the response is CORRECT. But, my BRX, it has gone in to overdrive with comm errors. (see attached pic). What is happening? Looking at C-more error screen, it reports read errors for items it has been reading normally for weeks WITHOUT A SINGLE COMM ERROR. I clear them, then go back, and now it has a different set of addresses. Again, addresses that it has been reading and writing for weeks without any errors.

    What gives?

    I stripped down my program down to just X and Y bits. The comm issue still appears sporadically. I have not upgraded nor downloaded any upgrades for a while since the last upgrade about 3 or 4 weeks ago. After the last upgrade, I had no issues until two days ago. Only difference being, swapping out a 8 point output card with a 16point output card. Surely, this is elementary and should not cause any comm issues. Could there have been a Microsoft like background update that I wasn't aware of?

    C-More is EA9 15" panel, 6.42 Firmware (it is buggy. Crashes often during development when you double click on database items (tags, messages, events) and on grouped objects on screen during edits. It completely SHUTS down the program. Earlier versions, had none of those issues. I say that because I maintain Earlier versions (going back to EA-7) as well as the newer versions for different customers.

    C-more Error codes: (Just one example)

    ETHERNET,DEV001,RDC24,2Byte Error Code PLC-001 (It has been reading C24 from BRX for weeks without any problems with default comm settings.)

    What is the C-more Error code "PLC-499: Error code 0x000e returned from PLC" for Do More Protocol? Nothing is specified in the help file.

    Puzzled and worried.
    Attached Files
    Last edited by skyfox; 05-26-2019, 06:03 AM.

  • #2

    C-more is displaying "PLC 010: Data size does not match" then it goes away after a second or two. Then re appears after another 10 to 20 seconds and the goes away again. Also, randomly getting PLC-001: PLC communications timeout. How do I track the source of this problem?


    • #3
      Is the BRX/C-more connected to a public network? Have you tried connecting to the PLC with USB or serial to see how itís behaving when Ethernet goes dumb?


      • #4
        Good Morning BobO,

        Appreciate the speedy response. I have not used a USB connection to date. It has always been an un-managed switch connecting HMI, BRX and my laptop. It has worked flawlessly without a single comm error up until now. As of few minutes ago, I am now unable to write to the PLC due to BRX throwing the Transport Protocol error at millisecond intervals, without really telling me the cause. I have been on-line editing for the last 6 hours without any issues untill this com error popped up. While this is happening, HMI is still able to send commands to the PLC and PLC responds correctly by carrying out what it was told to do.

        At a complete loss now. This is happening under both Windows 10 (64bit) and Windows 7 (32bit and 64 bit) OS environments.

        Attached Files


        • #5
          Connecting via something other than Ethernet gives us the chance to look at scan time and some diagnostic registers. If you have a USB POM, please try to get connected. If your Ethernet still works sporadically enough to read registers, there are a number of DSTs with potentially interesting stuff. Don't know the numbers but most names start with $Eth. There are also some ST bits of interest, most notably one flagging a comm stack overrun. Not in front of a computer now and working from (aging) memory.

          Also, have you tried disconnecting the C-more?


          • #6
            Just a thought, but have you updated the tag database of the Cmore to match the BRX with the new 16-point module in slot 3?
            Why worry? If you've done the best you can, worrying won't make it any better

            - Walt Disney


            • #7
              If you switch back to the 8 pt module in slot 3, does it resolve the issue?


              • #8
                Finally sorted it out. Sort of. It wasn't the BRX, C-More, nor the I/O card. Besides, I wouldn't think C-more would attempt to talk to the I/O card directly. At least not to a discrete I/O card.


                I swapped Ethernet cables for both the HMI and the PLC with shielded Ethernet cables.

                Still the same problem.


                Increased the Acknowledge timeout value in the C-more under PLC Protocol section. This helped in lowering the frequency of comm errors, but they kept coming in nonetheless. Albeit, once or twice a minute as opposed to every 15 seconds. But I believe this action was just masking the issue.


                The Ethernet switch was replaced with a brand new unit. A happy dance was auto triggered at the first 15,000 millisecond tick mark.

                Since then,

                C-more, The BRX, and my laptop, haven't had any

                "You Talkin' to Me?

                moments for the last 36 hours.

                Now for the Fixed it sort of part.....

                My trusty old compact Netgear Ethernet switch, which had served me well for the last 5 years, without a single complaint, in three different continents, decided to fail me after working flawlessly with the BRX C-more combo for weeks for no apparent reason.

                Here is the Sort of......

                That old Netgear switch, a 10/100, is chugging along without any issues as we speak, albeit, using a different set of hardware in another LAN.
                Not going to ask why. Happy the BRX and C-more are talking now with the new switch. That is all that matters for now.

                Last edited by skyfox; 05-30-2019, 12:18 AM.


                • #9
                  Could be that there was just too much traffic for the old Netgear CPU to handle. Hard to get too much traffic in most instances, but still possible.
                  If you have an urgent issue, please contact AutomationDirect's Technical Support team.

         Technical Support: 1(800) 633-0405 or (770) 844-4200 Email Tech Support


                  • #10
                    I assume that you tried power cycling the switch at some point during the debug and that didn't fix it, but I have definitely seen cases where the switch just got dumb and a power cycle cleared it.