Announcement

Collapse
No announcement yet.

P2K Not Saving Properly

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts


  • P2K Not Saving Properly

    I have a PLC which is not saving the project in the normal way.

    Project File Status = Not Saved
    CPU Project Status = Out Of Date

    Transfer the project to the PLC and

    Project File Status = Not Saved
    CPU Project Status = Up to Date

    Now save the file to the PC and

    Project File Status = Saved
    CPU Project Status = Out Of Date

    Transfer the project to the PLC and

    Project File Status = Not Saved
    CPU Project Status = Up to Date

    I can not get the two of them to be happy with the saved project, either one is out of date or the other is not saved. If I close the project and then reconnect it will say that there is Project Differences, but I know that they are the same. The only error showing on the error history is E04204 DL Buffer > 50% Full and memory usage is 6%. SystemReport.2.17.2018_10.34.15.zip


  • #2
    In your task named "Loading Bay Temperatures" you have a subrung "3.1" that has an END, but is not attached to rung 3. Delete this subrung and it should save.

    Click image for larger version

Name:	Rung.JPG
Views:	7
Size:	36.4 KB
ID:	111458

    Comment



    • #3
      Originally posted by PSeries_Eng View Post
      In your task named "Loading Bay Temperatures" you have a subrung "3.1" that has an END, but is not attached to rung 3. Delete this subrung and it should save.

      Click image for larger version  Name:	Rung.JPG Views:	1 Size:	36.4 KB ID:	111458
      Maybe an update so the software could flag that.
      Last edited by kewakl; 02-19-2018, 07:19 PM.

      Comment



      • #4
        Why isn't the compiler giving an error on that? More so, why is that an issue at all?

        Interestingly, I ran into the very same problem today. Save program > Program Up to date. Transfer program (runtime) > CPU up to date, but then immediately the program would not be up to day. Re-save the program > program up to date, immediately CPU becomes not up to date.

        Closed everything out, rebooted laptop (it had been up for quite a few days without a reboot), issue disappeared.

        Comment

        Working...
        X