Announcement

Collapse
No announcement yet.

productivity series email command - wheres the authentication?!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts


  • productivity series email command - wheres the authentication?!

    seriously just purchased a P1000 setup to replace an existing click setup ONLY because of the email instruction. start setting it up, only to realize that SMTP port 25 cant be changed, and NO authentication is supported... its 2018!!! there are NO anonymous SMTP servers around any more?

    i read another post from 3 years ago bemoaning the same thing... whats the deal?! why even advertise email if it doesnt work for any practical application?

    good chance i will be returning this PLC if email is never going to be updated to work right...


  • #2
    I asked the same question long time ago.
    I doesn't have that functionality. You'll have to stick to a local server and go from there.
    Yes, doesn't make any sense!

    Comment



    • #3
      Ya it does suck that Productivity cant really do practical email applications. You need to get a BRX if you want to do email. BoBO lit a fire under their development and brought in SSL connection capability so that email instructions can actually be used.

      Comment



      • #4
        Our Product Developers are in testing with new email features currently. If all continues to go well we should have major email changes to the Productivity before the end of the year. We have been working on this for some time and have had several setbacks, but we are close and appreciate your patience.

        Comment



        • #5
          PSeries_Eng, thank you!

          will this be a firmware and programming software upgrade? assuming this wont require new hardware...

          Comment



          • #6
            Originally posted by mburrus View Post
            PSeries_Eng, thank you!

            will this be a firmware and programming software upgrade? assuming this wont require new hardware...
            Yes, this will be firmware and software update only. No changes to hardware.

            Comment



            • #7
              I've tried the new Email command on the P1000 CPU. Gmail server, but keep getting Cannot connect to server error. (-288)
              I'm using Productivity Suite Programming Software v3.4.0.16 with the latest firmware P1-540 Filename: P1-540_1.2.7.37.adfw

              Switched back to the "Restricted Gmail SMTP server" and everything worked as expected.

              Do you have any reason why the Gmail SMTP server does not work?

              Thank you,
              Garry

              Comment



              • #8
                It's all about authentication which is no small hurdle for a PLC or even HMI to overcome. Our workaround for several years is to use a service to bounce them through. I pay $96 a year to AuthSMTP so that my HMIs and other hardware can send email alerts. All I had to do was create an account and send them an email to ask for a static IP address for the mail server.

                They have not changed that IP address for the 4 years we have been using them, and now I have 6 or 7 different customer systems all using that one package. I did upgrade it from the cheapest package to a couple of notches up due to the fact I had added customers and was getting close to the limit when one of them had a rash of alarms.

                As the account administrator, I get warning emails as I approach my 5000/month message limit (I never even get close to the data limit, these are simple alarm messages). They provide a nice web interface that has been very helpful in troubleshooting too. I know it would be great if we could get authentication in all of our machinery control hardware, but from my cursory understanding of what is involved, there is so much processing required to do that, a PLC is really not the right tool for the job. I choose to offload that responsibility to AuthSMTP and have spent less than an hour total setting that up and maintaining it.

                Comment



                • #9
                  I just sent an email to our test gmail account we have here and all works as expected.

                  1.) Is you CPU date and time current?
                  2.) Per the help file P142:
                  Note: You may have to enable the ability to allow less secure applications setting on your email server account.
                  If you have an urgent issue, please contact AutomationDirect's Technical Support team.

                  AutomationDirect.com Technical Support: 1(800) 633-0405 or (770) 844-4200 Email Tech Support

                  Comment



                  • #10
                    Hi OkiePC
                    The latest productivity software update was suppose to handle authentication.
                    Productivity Suite Release Notes Version 3.4.0.16 Release Date: 12/12/18
                    Improvements:
                    1.) Updated EMAL instruction to allow selection of Mail Account with corresponding status tags.
                    2.) Added new Mail Account in Hardware configuration to allow configuration of secure email servers (Gmail, Yahoo, AOL, etc.)
                    Etc.
                    Restricted Gmail SMTP server might work well for you and it is free.

                    I have tried the secure email server Gmail and Outlook. Both options have given me the error listed above.
                    Thanks,
                    Garry

                    Comment



                    • #11
                      Thanks P3K_ADC_Eng
                      I'll give it another try tonight and let you know.
                      Garry

                      Comment



                      • #12
                        I have made the PC and PLC time the same. They were only out by one hour.
                        I've also ensured that I've allow less secured apps on the account.
                        I am still getting the "Failed to get server address (-288)"
                        I can email the screen shots if you want.

                        Any other suggestions?
                        Thanks,
                        Garry

                        Comment



                        • #13
                          Would be best if you could go online and create a system report. This will provide us with any of the info we will need to try and duplicate. If you can't post here then please send into our tech support team and they will forward it to us.
                          If you have an urgent issue, please contact AutomationDirect's Technical Support team.

                          AutomationDirect.com Technical Support: 1(800) 633-0405 or (770) 844-4200 Email Tech Support

                          Comment



                          • #14
                            Thanks P3K_ADC_Eng
                            I'll do this tonight, and post.
                            Garry

                            Comment



                            • #15
                              Here is the system report:
                              SystemReport.1.5.2019_6.50.24.zip

                              Thank you,
                              Garry

                              Comment

                              Working...
                              X