Announcement

Collapse
No announcement yet.

Runtime transfer causing PLC shutdown (P-suite V3.3 and V3.4)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts


  • Runtime transfer causing PLC shutdown (P-suite V3.3 and V3.4)

    I have encountered the cases several times with different PLCs (P3-550, P2-550) in different locations, the error is as in the attached picture. It is kind of annoying especially when I doing it remotely (the programming station is local, I use remote desktop). Although re-transfer, or change the PLC mode will restart the PLC, but the plant has to restart the equipment one bye one. This makes me scared to make changes on the run.
    Attached Files


  • #2
    Suffering from the same issue, I thought it was network related but I have gone over everything and can't find any issues on that end.

    Comment



    • #3
      Can both of you try the below?:

      1. Can you save the project without errors?
      2. Do you have a back-up copy of the project? (Project compare can be used to find any possible differences)
      3. Does this happen during both run and/or stop mode transfers?
      4. Can you go online with the CPU and create a system report?

      Please send your system report into our technical support team so we can try to duplicate and begin our investigation.
      If you have an urgent issue, please contact AutomationDirect's Technical Support team.

      AutomationDirect.com Technical Support: 1(800) 633-0405 or (770) 844-4200 Email Tech Support

      Comment



      • #4
        1. Can you save the project without errors?
        Yes, I normally compile first then download. The only thing I feel is to add any new tags will cause this problem much more often.

        2. Do you have a back-up copy of the project? (Project compare can be used to find any possible differences)
        I back up all the times. Even a small change may cause this problem.

        3. Does this happen during both run and/or stop mode transfers?
        Both

        4. Can you go online with the CPU and create a system report?
        Not sure how to create the system report, please explain.

        Comment



        • #5
          Be online with the CPU:

          1.) Click on Help -> then Create System Report. Make sure 'include project with debug information' is selected.

          This will save a .zip file of the files we need. Then send this into our tech support team. https://support.automationdirect.com/techcontact.html
          If you have an urgent issue, please contact AutomationDirect's Technical Support team.

          AutomationDirect.com Technical Support: 1(800) 633-0405 or (770) 844-4200 Email Tech Support

          Comment



          • #6
            Done. I just created an empty project and downloaded to a P2-550; then added one 2d array, re-downloaded and the error happened again. No program.

            Comment



            • #7
              Can you provide more specifics?

              1.) What data type was the array?
              2.) How many elements? 255 x255?
              3.) Retentive selected?

              Any other details or a screenshot of the tag database showing options selected would be helpful.
              If you have an urgent issue, please contact AutomationDirect's Technical Support team.

              AutomationDirect.com Technical Support: 1(800) 633-0405 or (770) 844-4200 Email Tech Support

              Comment



              • #8
                int16, 16X8, retentive

                P2-550, P2-07B, Newest firmware, software 3.4.1.1

                Comment



                • #9
                  I can duplicate here on my end. I have entered a trouble ticket to our QA team to begin investigating. I will update this post once I hear back from them on a fix and/or workaround.
                  If you have an urgent issue, please contact AutomationDirect's Technical Support team.

                  AutomationDirect.com Technical Support: 1(800) 633-0405 or (770) 844-4200 Email Tech Support

                  Comment



                  • #10
                    Once you get the error and hit ok. Have u tried to download again?

                    We get the error the first attempt to download after the array is created, however, on the 2nd attempt it will download as expected.

                    We are still looking into the root cause.
                    If you have an urgent issue, please contact AutomationDirect's Technical Support team.

                    AutomationDirect.com Technical Support: 1(800) 633-0405 or (770) 844-4200 Email Tech Support

                    Comment

                    Working...
                    X