Announcement

Collapse
No announcement yet.

Colon appearing on tags

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts


  • Colon appearing on tags

    Working on a P1 program and noticed that when assigning a tag to an integer type area, the drop down is showing some duplicate tags - one normal and one with a colon at the end.
    kind of reeks havok on debugging. It appears most have to do with the default tags within timers, counters, etc. but I am not using the structured format.
    Any thoughts out there I should be concerned with?


  • #2
    These are for bit of word. So "tagname:1" would be the first bit of that integer tag. Some fields can take boolean or integer tags so it will give you the choice for either. Nothing to be concerned about.

    Comment



    • #3
      How come they don't appear in the tag database?
      Just don't want to be fooled when putting Cmore together.

      Comment



      • #4
        It will put a "+" beside the tagname so you can expand to bitsif you right click on the tag and choose "show bit of word" ( BTW help file P040 describes this)

        Click image for larger version  Name:	bow.PNG Views:	0 Size:	8.4 KB ID:	121785

        Comment



        • #5
          Thanks for the info. Don't use that functionality so didn't know. Maybe it will come in handy soon....
          Happy Easter!

          Comment



          • #6
            It is very handy when using arrays. when i set up coms I always have an array set up much bigger than I actually need and anything that will be communicated back and forth goes on that array. this way it is searching and writing in one chunk of memory and is much more efficient.

            Comment

            Working...
            X