Announcement

Collapse
No announcement yet.

Productivity2000 analog input module P2-08AD-1 Glitch

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Productivity2000 analog input module P2-08AD-1 Glitch

    When you press the little blue button on the P2-08AD-1 analog input 0-20mA module to enable the status screen, the current value momentarily goes high. This is an issue as any logic that is looking at the current measurement is erroneous triggered. We are using the module to monitor a Fire detector loop circuit. See image below for details.

    Click image for larger version  Name:	Fire Detector loop2.PNG Views:	0 Size:	82.5 KB ID:	122504

    In the logic, a fire system water deluge solenoid is triggered when the current reading is greater than 12mA. What we found is that when the screen times out and you press the blue button, it momentarily energizes the solenoid dumping the fire system. We've had to add a 2sec timer in the logic to delay the solenoid giving the module enough time to stabilize.

    Please investigate and let me know if you can replicate the problem and if a fix is available. Thanks
    -Moses
    Attached Files
    Last edited by machua; 05-04-2019, 10:04 PM.

  • #2
    what hardware revision is you P2-08AD-1? It will be the last one or two digits of the serial number on the module label. Could be either A or A1.

    Comment


    • #3
      Serial number ends with 6A

      Comment


      • #4
        Have you tried swapping the module out with a spare? If needed, call into our RA department to get the P2-08AD-1 replaced.

        Comment


        • #5
          We have 6 modules spread out in 1 local base and 2 remote bases (2 per base). They all randomly do that when awoken, so I think it's something common in them. The 2 second delay seems to have fixed the problem in this application but I just wanted to bring the issue to your attention.

          Comment


          • #6
            Please contact our technical support team to open a trouble ticket. We have contacted our supplier to begin investigating.

            Comment


            • #7
              Sent a PM to you machua. Please review and respond.

              Comment


              • #8
                Did this ever get verified by adc? Any update?

                Comment


                • #9
                  Too many issues do not get resolved/or resolution mentioned here.
                  I am still waiting (not really waiting anymore) for some resolution on some very early P3-550 CPU failures.

                  https://forum.automationdirect.com/f...like+doesn%27t
                  https://forum.automationdirect.com/f...613-cpu-lockup
                  https://forum.automationdirect.com/f...igned-pac-name

                  and some QoL issues
                  https://forum.automationdirect.com/f...comment-search

                  Comment


                  • #10
                    g.mccormick There was an issue with the modules firmware. Confirmed with vendor this issue has been fixed. The new firmware is shipping with datecode 19605 or higher (Year 2019, Month 6, Day 05). The overall revision of product is Rev A2 and higher.

                    Comment


                    • #11
                      Has an updated module firnware then been released as part of p2k firmware update?

                      Comment


                      • #12
                        g.mccormick Module firmware can't be updated in the field with the exception of intelligent modules (HSO, HSI). We only had one customer report this issue.

                        If you have a module that is needs replaced contact our RA team and we can get your module(s) replaced.
                        Last edited by ADC_CommTeam02; 03-25-2020, 12:59 PM.

                        Comment

                        Working...
                        X