Announcement

Collapse
No announcement yet.

Pending Data Change Lock Up in Data View

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Pending Data Change Lock Up in Data View

    I am using a P1-540 on Ver 3.5.0.16 software with ver 1.2.8.25 firmware.

    I am able to "lock-up" my Array of integers by creating a new Data View instead of clicking the Send Edits but in the Data View window.



    First I made a change inside my array of integers then instead of pressing Send Edits(Waldo Hat) I accidentally pressed Add Data View.

    Click image for larger version

Name:	2019-06-28 (4).png
Views:	305
Size:	34.1 KB
ID:	123654

    After the new Data View was made I could no longer Send the pending edits even if they were changed.
    I tried going into Stop Mode and transferring the project, removing the program from and Reinstalling into the PLC, restarting the software, and even a Power Cycle, nothing allowed me to make the change to the array tag.

    Click image for larger version

Name:	2019-06-28 (5).png
Views:	173
Size:	34.9 KB
ID:	123655


    Then, after going to the new data view that was created I can place the same integer array here and my changes can once again be made but I still can not make changes to that array inside of the original data view that it was placed in.

    Click image for larger version

Name:	2019-06-28 (7).png
Views:	174
Size:	34.7 KB
ID:	123656

  • #2
    Duplicated with P1-540 SW 3.5.0.16/FW 1.2.8.25
    Duplicated with P1-540 SW 3.5.0.16/FW 1.2.7.37 -- so it does not appear to be firmware related

    Could not duplicate using P1-540 SW 3.4.0.16/FW 1.2.7.37

    In a dataview tab, if a tag has a pending edit when the Add DataView button is clicked, that dataview fails to send data.
    Other array datatypes suffer from this. I tested boolean, float and string arrays - all fail to write after clicking on the Add DataView button while a pending edit has not been written.
    It does not matter the array datatype that has a pending edit when the Add DataView button is clicked - all 'ARRAY' sends fail in this dataview.

    If no pending edit/new dataview conflicts have happened - all edits can be sent.
    If ANY tag (array or non-array) has an edit pending and the new dataview button is clicked, no array data can be sent - but the single integer tag data CAN be sent.

    It seems that references to arrays get lost when the Add DataView button is clicked while an edit is pending.


    [edit change to Add DataView]

    Follow up, after the aforementioned issue inhibits the sending of array data, AutoEdit send STILL DOES WORK!
    Last edited by kewakl; 06-28-2019, 10:45 AM.

    Comment


    • #3
      We can also duplicate the issue. I have entered a trouble ticket to our development team.

      Comment


      • #4
        Just made another find on the problem that I have stated above.

        Losing the ability to make a change to a numeric entry does not seem to only happen within arrays. I have seen that it will also "Lock Up" my STMR Structure Numeric Tag. I have not tried this with all structure types.

        Click image for larger version  Name:	2019-07-11_LI.jpg Views:	0 Size:	133.2 KB ID:	123874
        If going through the same process stated above and if you have a structure in the original Data View Tab you will also lose the ability to change those numeric tags that are in the structure as well.

        Comment


        • #5
          This has been flagged as an issue. This has been fixed and software is in final QA.

          Comment


          • #6
            New 3.5.1.2 is now available on the store that fixes this issue.

            Comment


            • #7
              I experienced the same problem with version 3.5.1.2. So I upgraded the Firmware on my P1-540 still no luck. Then I installed Version 3.5.2.2 and still was not able to send edits with Dataveiw to an Array Index.
              Then I came across this thread and put the Array into Dataview2 and viola it works now but not in Dataview1.

              Edit: I am using Firmware 1.2.8.30 now. Not sure what was on it before.
              Last edited by Levi G; 12-24-2019, 05:44 PM.

              Comment

              Working...
              X