Announcement

Collapse
No announcement yet.

P3-16AD-2 Not indicating input voltage

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts


  • P3-16AD-2 Not indicating input voltage

    Rack config
    P3-11B
    P3-01AC
    P3-550
    P3-16AD-2
    P3-16ND3
    P3-16TD2
    P3-16AD-2
    P3-16AD-2
    P3-16AD-2 <-----SLOT 6 Channels 3 and 4
    P3-16TD2
    P3-16TR
    P3-16TR

    Issue: With some reliability, 2 channels of the P3-16AD-2 card in slot 6 will not indicate the input signal value under certain conditions.
    In all cases, I could measure an input voltage [Fluke 87 V] and (IIRC) the LCD display indicated voltage on the inputs.

    I was seeing this issue while testing our product, but not with the 'verification' equipment that we use to verify our electronic/electrical circuits and connections.
    Replacing the card seems to have resolved this issue in three stations.


  • #2
    We have had the same issue with the P2-16AD-2 module. I guess they can't read differential analog inputs even if a dvm can.
    P2K analog input problem (P2-16AD-2)

    11-29-2018, 08:54 AM
    We are having an issue with the P2-16AD-2 module. We can read some signals (0-10v) but not others. We checked bonding, grounding any unused channels moving the nonworking signals to different channels, checking for noise and nothing works. The problem signals are differential. Right now we are looking at the input impedance of the P2-16AD-2 module, it is only 250k ohms. I think this may be an issue with the modules ability to update its sample and hold for some signals. We are trying a P2-04AD it has 1m ohms input impedance, and if that doesn't work we will try a signal conditioner. If anyone has input I would appreciate any feedback and I will update you on what we find here.

    Thanks

    Comment



    • #3
      I am not trying to read a diff signal.
      I don't know if you were just mentioning that.

      All input channels on the P3-16AD-2 are commoned together with the 24v psu --- in the module.
      For reading low-current capability voltage signals, I use op amps in voltage follower mode to drive the analog inputs.
      usually LM741 or TL081.
      I have had issue with TL081 being too FAST, so I went with the LM741 and problem solved. Attribute to slew rate.

      Comment

      Working...
      X