Announcement

Collapse
No announcement yet.

Productivity Suite - Tag Database not opening

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Productivity Suite - Tag Database not opening

    Hi, I'm using the Productivity Suite IDE to program a P3-550E. The problem is when I click on "Tag Database" from either the top menu or the left sidebar, it doesn't open. No error message, no indication that anything is wrong. The window didn't spawn inside or outside of the main window, it's not accessible by messing around in the "Window" menu, it's not on the Windows 10 taskbar. It either fails silently and doesn't open the Tag Database window, or (as a coworker suggested) it's opening somewhere offscreen, but somewhere I can't access.

    Has anyone else had this problem?

  • #2
    It will help if you can provide the software version of P-Suite you're using.
    Why worry? If you've done the best you can, worrying won't make it any better

    - Walt Disney

    Comment


    • #3
      Try selecting Tools -> Reset Screen Layout.

      Comment


      • #4
        Jim Andrews Do you usually have a second monitor that is now disconnected?
        If so, that is where the Tag Database window most likely ..... is.

        Todd Dice it probably makes no difference. PSuite (and CLICK) have NO IDEA where their respective child windows live. One would think that DSS should get involved.

        Comment


        • #5
          This was added as an improvement:

          Productivity Suite Release Notes Version 3.2.0.12 Release Date: 4/18/18

          1.) Any off-screen panels that were set up on multiple screens are now automatically moved back if only one screen is detected.

          Comment


          • #6
            Originally posted by ADC_CommTeam02 View Post
            This was added as an improvement:

            Productivity Suite Release Notes Version 3.2.0.12 Release Date: 4/18/18

            1.) Any off-screen panels that were set up on multiple screens are now automatically moved back if only one screen is detected.
            I was pretty sure I remembered times in the past couple of years where a window opened on a screen that no longer existed, so I went and tested this right now and 100% that feature does not function.

            What I did was:

            Open Productivity Suite 3.5.2.2 (current latest)
            Open tag database to verify it auto opens the window on the second display where it normally does
            Close tag database.
            Open again to verify a second time it auto opens on display 2
            Close tag database
            Turn off second monitor
            Open "display settings" in windows
            Unplug monitor cable
            Verify in display settings that the second monitor no longer shows up in windows at all
            Open tag database. This opened on screen #2 that no longer exists and I cannot see the tag database at all.



            OS is Windows 10 x64 Pro for Workstation v.1909 (current latest stable release)
            Monitor 1 (primary) is connected with Display Port
            Monitor 2 is connected with HDMI. This is the one I unplugged to test
            Last edited by MikeN; 02-06-2020, 09:04 AM.

            Comment


            • #7
              Ok thanks. I will report this to our development team.

              Comment


              • #8
                MikeN
                Can/will you redo your test.
                this time, close/reopen the software after it fails to move the window to an existing screen?
                ​​​​​​​thx

                Comment


                • #9
                  Originally posted by kewakl View Post
                  MikeN
                  Can/will you redo your test.
                  this time, close/reopen the software after it fails to move the window to an existing screen?
                  ​​​​​​​thx
                  Did the test again, and after closing Productivity Suite and then starting the software up again without the second monitor plugged in, it will move Tag Database window to the main monitor when I try to open the tag database. So I guess the feature does kinda work, but the software has to be restarted in between.

                  Comment


                  • #10
                    Thanks!
                    That is what I wished to have explained--and not by me.
                    I can't be the only pacsuite user with *issues*

                    Comment


                    • #11
                      Great, thank you. Resetting the screen layout fixed it.

                      Comment


                      • #12
                        Originally posted by Jim Andrews View Post
                        Great, thank you. Resetting the screen layout fixed it.
                        I bet it destroyed any layout that you worked hard to setup for your workflow.
                        I like having the Dataview and tagdatabase docked in the same window and [Apps][Instructions] and [Tasks] to be collapsing flyouts on the left side of the editor. I need all of the width available to the task editor.
                        I also like having some of the child windows docked together in windows that seem to fit their contexts. Click image for larger version

Name:	docked.png
Views:	51
Size:	99.4 KB
ID:	128678


                        Resetting the layout destroys that for me.

                        Comment

                        Working...
                        X