Announcement

Collapse
No announcement yet.

Board Manager Not working Bad CRC

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Board Manager Not working Bad CRC

    Hello,

    I can't seem to get the board manager to download the P1AM-100, it faults with bad CRC as pictured in the attachment. I've tried the regular download and install and now I'm using the windows 10 APP which worked a little longer before repeating the error. I've also tried deleting everything in the ArduinoData\staging\packages folder and downloading again but still same error.
    Please let me know if there's something else to try.

    Attached Files

  • #2
    Here is some better info from the IDE:

    Code:
    CRC doesn't match, file is corrupted. It may be a temporary problem, please retry later.
    java.lang.RuntimeException: java.lang.Exception: CRC doesn't match, file is corrupted. It may be a temporary problem, please retry later.
    at cc.arduino.contributions.packages.ui.ContributionM anagerUI.lambda$onInstallPressed$2(ContributionMan agerUI.java:175)
    at java.lang.Thread.run(Thread.java:748)
    Caused by: java.lang.Exception: CRC doesn't match, file is corrupted. It may be a temporary problem, please retry later.
    at cc.arduino.contributions.DownloadableContributions Downloader.download(DownloadableContributionsDownl oader.java:105)
    at cc.arduino.contributions.DownloadableContributions Downloader.download(DownloadableContributionsDownl oader.java:60)
    at cc.arduino.contributions.packages.ContributionInst aller.install(ContributionInstaller.java:113)
    at cc.arduino.contributions.packages.ui.ContributionM anagerUI.lambda$onInstallPressed$2(ContributionMan agerUI.java:172)
    ... 1 more

    Comment


    • #3
      What version of the IDE are you using? Are you on 64 or 32 bit windows 10?


      Comment


      • #4
        If it helps:
        I just downloaded/installed the board manager entity.
        Win7-64ProSP1
        Arduino 1.8.10

        Comment


        • #5
          Originally posted by kewakl View Post
          If it helps:
          I just downloaded/installed the board manager entity.
          Win7-64ProSP1
          Arduino 1.8.10
          Thanks, so no problems when you installed it?

          Comment


          • #6
            Samuraimarc Are you on a network that an IT department may put certain restrictions on? Sometimes firewall settings may cause a problem.

            When you look in the filepath: C:\Users\USERNAME\AppData\Local\Arduino15\staging\ packages do you see a file named "P1AMCore-1.6.20.tar.gz"
            And if what is it's file size?

            Can you paste the exact JSON link you are using for the board manager?
            Last edited by FACTS_ENG_TEAM1; 02-11-2020, 12:32 PM.

            Comment


            • #7
              I'm on 64- bit win 10 pro v1903.
              P1AMCore-1.6.20.tar.gz = 4,037 kb
              I'm able to get through the network and I even tried hot spotting my phone just to make sure. I was able to get it on a Linux box just fine through the same network.

              JSON used = `https://raw.githubusercontent.com/facts-engineering/facts-engineering.github.io/master/package_productivity-P1AM-boardmanagermodule_index.json`

              Comment


              • #8
                Originally posted by FACTS_ENG_TEAM1 View Post

                Thanks, so no problems when you installed it?
                No problem installing. I did not attempt anything else, though.

                Comment


                • #9
                  Forgot to add arduino version 1.8.11

                  Comment


                  • #10
                    Ok i finally got it. The issue was the arduinoOTA-1.2.0-windows_386.zip file. it tries to lookup http:// unsecure site instead of https:// I manually downloaded https://downloads.arduino.cc/tools/a...indows_386.zip and put it in the staging folder and retried the install and it worked.

                    Comment


                    • #11
                      Thanks for the update on your solution. Glad you got it working. I'll see if we can change something to avoid this issue with others in the future.

                      Comment

                      Working...
                      X