Announcement

Collapse
No announcement yet.

P1AM LED Blinking Slowly/Unable To Upload Sketch

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • P1AM LED Blinking Slowly/Unable To Upload Sketch

    I am unable to upload a basic sketch to the P1AM out of the box.
    1. Program compiles without errors
    2. P1AM appears when connected and I am able to select the COM port.
    3. Upload times out 'An error occured while uploading the sketch'

    LED is flashing on/off slowly (No sketch has previously been uploaded)

    Any suggestions?

  • #2
    What operating system version are you using?
    What IDE version are you using?
    Is it an On/Off flashing pattern or fading in and out pattern?

    Comment


    • #3
      Windows 10 Pro
      Arduino IDE 1.8.12
      Fading in and out

      I was able to get this to stop holding down the reset button, performing an upload and releasing just as the IDE diagnostic said 'Uploading'. The next issue was that after the program was loaded I am no longer able to connect to the controller. When the controller is connected to the computer the com port does not appear...this is where I am stuck now... no controller is no longer recognized.

      Comment


      • #4
        When you watch your usb devices in device manager while plugging up the device do you see any new devices populating? If not then possible issue with cable, P1 port, or pc port.
        If a new device displays see if it has a symbol on it. If so updating usb driver may be necessary.( if there is a problem it may show up in Universal Serial Bus COntrollers)
        If a new device displays with no symbols click on it and see what port it gets assigns. ( If it does install it should show up in Ports(Com & LPT) )

        Comment


        • #5
          Hi,
          I got a P1AM Starter Kit yesterday, and was trying to upload some example programs, I was having some issues uploading programs with Arduino IDE, so I pushed the "reset" button on the P1AM - 100 and now Arduino IDE can't find the P1AM - 100 anymore. I tried totally disconnecting the power and reconnecting but to no avail.

          I am using Arduino IDE on Linux

          I noticed that after I had pressed the reset button, the yellow LED stop flashing as it had previously.

          Any help would be appreciated. Thanks.

          Comment


          • #6
            I am having similar problems as the first post.
            I am unable to upload a basic sketch to the P1AM out of the box.
            1. Program compiles without errors
            2. P1AM appears when connected and I am able to select the COM port (com3).
            3. Upload times out 'An error occured while uploading the sketch'

            The difference is my LED is on constantly.

            I pushed the reset and tried again, no difference.

            I'm using windows 10.

            Comment


            • #7
              frankG, are you sure the com port is still showing up after doing the RESET?

              Comment


              • #8
                The first thing you guys should do is make sure it shows up in Device Manager(Windows) or /dev(linux as TtyACM0 I think).

                If you have it plugged into a USB hub, I would try directly plugging it in to the PC. The P1AM re-enumerates during the upload process and I've seen a couple hubs mess with this.

                You probably have, but also double check your program didn't actually get uploaded. the Arduino IDE can be a little finicky and I've seen it throw an error even though it programmed correctly.

                Comment


                • #9
                  OK, I tried again. Plugged directly into PC motherboard with no results (the file at /dev/ttyACM0 does not exist) the only ports available in Arduino IDE are /dev/ttySO and /dev/ttyS1, but neither of those are it.

                  The fact that /dev/ttyACM0 did exist before I pressed the RESET button on the P1AM -100 is making me wonder if the device is gone bad? Also tried on a different PC with another USB cable with no results.

                  Comment


                  • #10
                    Do you get a breathing/fading LED pattern? Pressing the reset button doesn't affect device memory, so I wouldn't expect it to do anything permanent.

                    Comment


                    • #11
                      Thanks for your prompt response!

                      It did have a fading on / off pattern before I pressed the RESET button, after pressing RESET its always off.

                      Comment


                      • #12
                        No problem! Just to double check, you're running a real linux PC and not a VM right?

                        The fading pattern means the P1AM is in bootloader mode. The IDE does this before actually flashing the program. Afterwards it resets and starts executing the program. The only time I've personally seen a board go from "Recognized by the PC > bootloader > reset > not detected" is when there is something in the program that is crashing it or not allowing it to service the USB port. This is often a "while(1)" with no internal code or trying to read a NULL pointer.

                        What I'd try for you, is to manually put it into bootloader and then put the basic blink example on. You get to bootloader by quickly double tapping the reset button. This might help us diagnose things a little further.

                        Comment


                        • #13
                          Yes, a real linux PC.

                          That fixed it, I am now able to upload programs again. I can upload 1 program in one power session, after that Arduino IDE throws this error: any ideas?

                          Caused by: processing.app.SerialException: Error touching serial port '/dev/ttyACM0'.
                          at processing.app.Serial.touchForCDCReset(Serial.java :107)
                          at cc.arduino.packages.uploaders.SerialUploader.uploa dUsingPreferences(SerialUploader.java:136)
                          ... 5 more
                          Caused by: jssc.SerialPortException: Port name - /dev/ttyACM0; Method name - openPort(); Exception type - Port busy.
                          at jssc.SerialPort.openPort(SerialPort.java:164)
                          at processing.app.Serial.touchForCDCReset(Serial.java :101)
                          ... 6 more


                          Comment


                          • #14
                            Do you have any serial monitor windows open? It also might be a a quirk with linux/arduino/samd, what version of Arduino are you using?

                            Comment


                            • #15
                              using Arduino IDE 1.8.11. No serial monitor windows are open.

                              what "Programmer" should be selected in Arduino IDE > Tools ?

                              Comment

                              Working...
                              X