Announcement

Collapse
No announcement yet.

C-More to Do-More PLC Communication Timeout

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ROleskie
    replied
    It's a STRIDE industrial unmanaged Ethernet switch part # SE2-SW5U. I set static IP addresses for both the HMI and Do-More PLC. I does look like the HMI has an option for DHCP, do you think I'd be better off trying that?
    Thanks,

    Leave a comment:


  • jackson
    replied
    What kind of Ethernet switch do you use? If it is a managed switch with RSTP turned on, it may take a bit for the Ethernet link to come up. If it is STP, it will take even longer. 30 seconds would be pretty short in this case.

    Leave a comment:


  • BobO
    replied
    Originally posted by Mike Nash View Post
    Just thinking out loud, but if you have DHCP set for the PLC and it gets set to another IP address when it boots, would the Cmore know this or still try to connect to the old IP?

    If this shows my networking savvy is rather low, feel free to ignore me.
    Do-more CPUs don't use DHCP, only ECOM100.

    Leave a comment:


  • Mike Nash
    replied
    Just thinking out loud, but if you have DHCP set for the PLC and it gets set to another IP address when it boots, would the Cmore know this or still try to connect to the old IP?

    If this shows my networking savvy is rather low, feel free to ignore me.

    Leave a comment:


  • ROleskie
    replied
    HMI Eng,
    When we turn on the PLC we wait 30 seconds maybe before giving up and rebooting the HMI. I'll try this test again and wait longer, then report back what happens.
    Thank you,

    Leave a comment:


  • HMI Eng
    replied
    How long are you waiting? Does the C-more seems to be updating in this period of time? The errors will buffer in the panel and take a minute to clear out.

    If it never connects back with the Do-More then there is a problem.

    Leave a comment:


  • ROleskie
    started a topic C-More to Do-More PLC Communication Timeout

    C-More to Do-More PLC Communication Timeout

    I have a Do-More PLC and an EA9 C-More connected via Ethernet, and working fine under normal conditions. I leave the C-More powered up when the main power is turned off, so the PLC is off at this point. I get the PLC-001 PLC communication timeout error on the C-More when the PLC is off, understandably so.

    The problem I'm facing is that the error does not clear after the PLC boots up. The communication error remains. The only way I can get it to clear is to reboot the C-More after the PLC is running.

    Is their any way to get the error to clear itself after the PLC comes on?

    Thank you,
Working...
X