Announcement

Collapse
No announcement yet.

Cmore Micro Hard Buttons

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts


  • Cmore Micro Hard Buttons

    I am using a Micro EA1-T4CL and a P1-540 -- over RS-232.
    I want to make toggles using the buttons/LEDs.

    I am using duplicate code that I have used in the past, and it is not consistent.
    However the original code uses screen button objects and is communicated over ethernet.
    This project is using the hard blister buttons on the HMI and is communicated over RS-232.

    Code:
    .
    .      BTN:1        MEM:1                     MEM:1
    .-------]/[----------] [-------+---------+-----(O)
    .                              |         |
    .                              |         |
    .      BTN:1        MEM:1      |         |    LED:1
    .-------] [----------]/[-------+         +-----(O)
    .
    .
    .
    [EDIT] The blister buttons do not support user-configures Momentary/Set/Toggle. They just report the IMMEDIATE state.
    The following seems to resolve 'my' issue. I 'think' that the difference is that original HMI project used SET for the Object Type - I cannot find any support for this mode in the blister buttons.
    Code:
    .
    .      BTN:1                                  BTN_1
    .-------]^[------------------------------------(O)
    .
    .      BTN_1        MEM:1                     MEM:1
    .-------]/[----------] [-------+---------+-----(O)
    .                              |         |
    .                              |         |
    .      BTN_1        MEM:1      |         |    LED:1
    .-------] [----------]/[-------+         +-----(O)
    .
    .
    .
    Last edited by kewakl; 10-01-2018, 10:49 AM.
Working...
X