Announcement

Collapse
No announcement yet.

C-More Modbus TCP

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • CMachine
    started a topic C-More Modbus TCP

    C-More Modbus TCP

    I am trying to connect a C-More screen to a Micro850 PLC using Modbus TCP/IP via a crossover cable.

    I can get it to connect and transfer data if I allow the Micro800 to obtain the IP automatically using DHCP and then copy that IP Address over to the C-More. It shares all data just fine, no issues. However if I try to use a static IP I can't get either to communicate.

    I've followed the AutomationDirect bulletin, at http://support.automationdirect.com/docs/an-ea-015.pdf. I know it can function, I just think I'm missing something with the addressing.

    My setups follow :
    Micro850 Screen : http://i.imgur.com/pJaRV6G.png

    C-More Screen : http://i.imgur.com/FdBzOPK.png

    Could anyone provide an IP and an explanation for me to try out?

  • CMachine
    replied
    Edit : Thank you both! The help is greatly appreciated!

    Got it, my values that worked are :

    Micro850
    IP : 192.168.0.2
    Subnet : 255.255.0.0

    Panel Manager
    IP : 198.168.0.2

    Touch Panel Network
    Ethernet Port Tab IP : 198.168.0.1
    Subnet : 255.255.0.0





    Leave a comment:


  • P3K_ADC_Eng
    replied
    Panel Manager= Micro850 192.168.0.1
    Touch panel network= Cmore 192.168.0.2

    If needed, give our tech support a call, they will get you up going quickly.

    Leave a comment:


  • CMachine
    replied
    Originally posted by scott.lawrence View Post
    >they state to use the same IP

    yes, for communicating. But the actual IP of the HMI, this setting is done under Touch Panel Network. What do you have there?
    Ahh, I just noticed the Touch Panel Network. At the moment it is empty.

    Would I have the Touch Panel Network IP = Micro850 IP?

    Leave a comment:


  • P3K_ADC_Eng
    replied
    What that statement is saying is in Panel manager the IP address needs the same IP address as it is setup in you PLC. The actual panel IP address is it's own separate IP address. Just change you panel IP address to 192.168.0.2 and all should work.

    Leave a comment:


  • scott.lawrence
    replied
    >they state to use the same IP

    yes, for communicating. But the actual IP of the HMI, this setting is done under Touch Panel Network. What do you have there?

    Leave a comment:


  • CMachine
    replied
    I thought the same thing, however in the AutomationDirect bulletin for setting this up they state to use the same IP. Unless I'm missing something, but the examples given show the same IP.

    Code:
    For Ethernet:
    In C-more Panel Manager, choose the “Modicon
    Modbus TCP/IP Ethernet” option. Enter in the
    IP address of the AB Micro 800 PLC that can
    be found in the same area as the Modbus RTU
    serial port setup

    Leave a comment:


  • scott.lawrence
    replied
    you can't have the IP of the HMI & the IP of the Micro the same....

    each device on your network needs it's own IP address

    Leave a comment:


  • CMachine
    replied
    I am using the same address, 192.168.0.1.

    It seemed a bit odd to use the same IP, but that's what the Technical Bulletin stated.

    Leave a comment:


  • P3K_ADC_Eng
    replied
    What is the IP address that you have setup for the Cmore panel itself? 192.168.0.?

    You can set this up in the project (touch panel network) or via the panel directly.

    Leave a comment:

Working...
X