Announcement

Collapse
No announcement yet.

Node Disable Headless C-more

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • JeffSa
    replied
    OK, got this to working. Apparently I had a typo in my %% tag name.

    Now I do notice that I have to change screens after the %% tag changes states because it stops all communications with all PLCs. Once I navigate to a different screen and back I get a few 0x0004 errors from the unchanged nodes then it proceeds as normal.

    Leave a comment:


  • HMI Eng
    replied
    No, it does not require a power cycle.

    Leave a comment:


  • kewakl
    replied
    Does the headless require a power cycle after setting these %DISABLE% bits?

    Leave a comment:


  • RoloTomassi
    replied
    I apologize for any confusion. This was tested on my RHMI, but in order to keep screenshots clean and simple afterwards, I started a simple scrap project for image captures. I just selected any panel in the Panel Manager for example purposes.

    Leave a comment:


  • HMI Eng
    replied
    Tested this with an EA9-T7CL as Rolo did, but also with an EA9-RHMI, v6.53 on both with no issue. Seems to be working correctly.

    Leave a comment:


  • RoloTomassi
    replied
    Take a look at the attached images.
    • The Device Name in the Panel Manager window is DEV001.
    • An internal tag is created with the name %DEV001_DISABLE% in order to disable error reporting when the node is offline.
    • A numeric display is added to the screen in order to allow the panel to poll an address from the PLC.
    • A pushbutton object is created to allow the user to toggle the %DEV001_DISABLE% tag off and on.
    • I tested this with the RHMI and it appears to be working as expected.
    I am using C-More version 6.53
    Attached Files

    Leave a comment:


  • HMI Eng
    replied
    No that was not dropped. We'll take a look at it.

    Leave a comment:


  • JeffSa
    started a topic Node Disable Headless C-more

    Node Disable Headless C-more

    I was trying the CM525 method to disable select PLC nodes and it doesn't appear to be working. Initially I thought it was because I had _ in the node name, but doesn't work even after removing this. Is this something that got dropped in the headless?
Working...
X