Announcement

Collapse
No announcement yet.

Using multiple Cmore panels with a productivity 2k

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Using multiple Cmore panels with a productivity 2k

    I am using a cmore panel connected to a productivity 2k plc to do an assembly line takt timer for our factory. We decided we wanted to display this information on some tvs located along the assembly line. So I added a EA9RHMI to my control panel. I loaded the same program that I was using on the original panel and switched the panel type and changed the ip address on it to allow it to talk with the productivity plc.

    So I have the following devices on the network.

    Productivity PLC 2k is 10.10.10.10
    EA9 cmore 10.10.10.2
    EA9 RHMI 10.10.10.3
    They are all connected to a unmanaged switch

    We are using the hmi located at the control box with the address 10.10.10.2 to change different production numbers etc on the plc. I have the plc setup to change the displayed screen when break time occurs, lunch time etc. I get the screen to change properly on the 10.10.10.2 hmi when the break events etc occur and sometimes on the rhmi located at 10.10.10.3.

    My issue is getting them to update properly on the 10.10.10.3 display sometimes it will stay on the screen that was previously displayed when the condition is no longer active and the 10.10.10.2 has updated to the new screen.

    Wondering what to look at on my side to get this straightened out.

    Thanks
    Adam

  • #2
    I have noticed (at least with the EA7) I had to 'send' the GOTOSCRN more than once.
    Please post a snippet of your code that changes the screen.

    Comment


    • #3
      Originally posted by kewakl View Post
      I have noticed (at least with the EA7) I had to 'send' the GOTOSCRN more than once.
      Please post a snippet of your code that changes the screen.
      I am just having my logic do a copy data to the v memory location that the screens are referencing. How would I do a "send" the "go to screen" more than once?

      Comment


      • #4
        Originally posted by imberiman View Post

        I am just having my logic do a copy data to the v memory location that the screens are referencing. How would I do a "send" the "go to screen" more than once?
        I had to write the screen number, dwell a bit, then write a 9999, dwell a bit, then write it again.
        Keep in mind that this was EA7 - with a screen saver activated. I have since disabled all of the screensavers on this line. Whitescreen/blackscreen issues link

        Comment

        Working...
        X